0

I am trying to install Ubuntu on an empty, MBR, NTFS-formatted 500GB Samsung SSD. To do this, I downloaded ubuntu-18.04-desktop-amd64.iso onto my main hard drive, a Windows 10, 1TB NVME drive. I created a "live USB" using Rufus, writing in ISO mode (default), selecting MBR Partition Scheme for BIOS or UEFI (default), NTFS file system so I could select the 4096 cluster size shown in the tutorial. All other settings were default. The live USB seems to work fine.

When I restart my computer with the live USB set as the highest priority boot disk, I am presented with a command-line interface and the following message:

GNU GRUB version 2.02~beta2-36ubuntu3.17

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

grub>

I was not presented with any other option. I tried downloading an older version of Ubuntu: ubuntu-16.04.4-desktop-amd64.iso, thinking there was an issue with the current version. I had the same error. I tried to restart without luck. I am posing this question because while there seem to be a number of posts seeking to address this issue, none of the solutions have worked for me.

Any leads or step-by-step advice for a less-technical person are appreciated.

2
  • 1
    ntfs file system for the usb sounds problematic. Usually they are fat, maybe ext4. Doubt you can boot Ubuntu off an ntfs drive. – Organic Marble Jul 18 '18 at 3:51
  • If you have Windows 10 in UEFI boot mode, you want new SSD as gpt and install Ubuntu in UEFI boot mode. UEFI only USB key, just extract ISO ( 7 zip or similar) to FAT32 formated flash & set boot flag. askubuntu.com/questions/395879/… & askubuntu.com/questions/743095/… Only use Something Else install option. – oldfred Jul 18 '18 at 14:36
0

This message is to be expected if you selected NTFS as your filesystem whereas the GRUB bootloader of Ubuntu wasn't compiled with NTFS module support (which means that GRUB can't read its configuration file and bails out).

Why did you change the file system in Rufus?

The default from Rufus with Linux ISOs is FAT32 and you should bear in mind that Rufus tries to select the options (file system, etc.) that are most likely to ensure that your USB will boot. So, unless you know what you are doing, you shouldn't try to second-guess the "best" options to use. Else, you will get into exactly the kind of issue you reported...

Also, you should have gotten a prompt asking you whether you wanted to create your USB in ISO or DD mode, and explicitly advising you to try first in ISO mode and then recreate your USB in DD mode if you encountered an issue. Have you tried that?

Rufus is trying its best to help YOU so that you can avoid the many pitfalls associated with booting. So please don't ignore what it tells you...

2
  • The official Ubuntu tutorial says the cluster size should be 4096 bytes. FAT32 did not allow that option. So, I was left to pick one of the two settings. – user2205916 Jul 18 '18 at 12:44
  • The cluster sizes available depend on the total size of your drive (and I'd be very curious to see a user report where Ubuntu fails to boot because of FAT32 cluster size, as it seems very unlikely), so it's puzzling that Ubuntu would advise to use a specific cluster size for FAT32, as this is not something that can be controlled. Can you point out where you saw that recommendation about the cluster size? – Akeo Jul 18 '18 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.