0

I'm puzzling over this one. I've installed all the drivers and packages recommended by Brother and then gone through this entire post (Brother scanner not working in Ubuntu 16.04 though driver installed) and done everything recommended (includeing sane extras).

I'm running Ubuntu 17.10 The printer is Brother DCP-L2550DW

Scanner still doesn't work. sane-find-scanner finds nothing:

# sane-find-scanner will now attempt to detect your scanner. If the # result is different from what you expected, first make sure your # scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that # you have loaded a kernel SCSI driver for your SCSI adapter.

# No USB scanners found. If you expected something different, make sure that # you have loaded a kernel driver for your USB host controller and have setup # the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports # can't be detected by this program.

However I get this

$ scanimage -L

device `brother4:net1;dev0' is a Brother DCPL2550DW DCP-L2550DW

Ultimatly, it's not showing up somewhere.

$ brscan-skey -l

DCPL2550DW : brother4:net1;dev0 : 192.168.1.4 Not responded

`

0

from this Ubuntu bug report, post #25

https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1728012

it is suggested you set up two symbolic links;

sudo ln -sfr /usr/lib64/libbrscandec* /usr/lib/x86_64-linux-gnu

and

sudo ln -sfr /usr/lib64/sane/libsane-brother* /usr/lib/x86_64-linux-gnu/sane

  • Thanks for your reply. I tried adding the links but it still doesn't work. It seems like the symbolic links worked best for brsane3. I've looked through the bug report and it still looks like there isn't a best way to get brsane4 (what i'm using) to work. – Amy Jul 19 '18 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.