2

I got this new laptop, installed 18.04 on it, and so far I can't get the audio to work (both internal/external speakers). The card exists, and in audio settings it seems normal and microphone works.

0 [PCH]:
HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xec228000 irq 134

In another question, the suggestion was to do this but it didn't work for me:

sudo nano /etc/modprobe.d/alsa-base.conf 
add line : options snd-hda-intel model=pch position_fix=1

Thanks in advance.

  • Can confirm that! But sound through Bluetooth boxes/headphones works. Does yours right top corner around the power button run also very hot on normal tasks? This issue is also mentioned here and here. – DMT Aug 28 '18 at 7:40
  • 1
    Hi there. Thanks for replying. I ended up giving up. I think the issue is coming from the laptop itself, we tried so many things and nothing worked, but we didn't try bluetooth. I then installed Fedora, got some audio, but after 10sec the audio died. We concluded about the hardware because all distro we tried didn't work, but the bluetooth worked. USB-C headphones too. – Raphael Leroux Aug 29 '18 at 12:20
  • Still no sound with Ubuntu 18.10. – DMT Oct 20 '18 at 19:12
  • I've opened another issue regarding this notebook. It's about overheating. Would be very helpful, if you could share your experience here: askubuntu.com/questions/1087672/unusually-hot-asus-ux391ua – DMT Oct 27 '18 at 9:12
  • Does shutting down the computer completely (not restart. an actual cold bootup) and booting straight to linux fix the problem? it does for me on a very similar issue – Hilikus Dec 11 '18 at 4:29
1

After some help from https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1784485 I finally fixed the problem.

It requires new kernel and some manual patching.

First download kernel source and extract it

wget https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.12.tar.xz
tar Jxf linux-4.19.12.tar.xz

Install necessary packages

sudo apt-get install build-essential libncurses-dev bison flex \
             libssl-dev libelf-dev

Copy kernel config

cd linux-4.19.12/
cp -v /boot/config-$(uname -r) .config
make defconfig

Add support for UX391UA

Add line to file sound/pci/hda/patch_realtek.c

SND_PCI_QUIRK(0x1043, 0x10a1, "ASUS UX391UA", ALC294_FIXUP_ASUS_SPK)

In patch format

--- patch_realtek.c.bck 2018-12-21 14:15:25.000000000 +0100
+++ patch_realtek.c 2018-12-30 16:13:23.970326312 +0100
@@ -6584,6 +6584,7 @@
    SND_PCI_QUIRK(0x1043, 0x13b0, "ASUS Z550SA", ALC256_FIXUP_ASUS_MIC),
    SND_PCI_QUIRK(0x1043, 0x1427, "Asus Zenbook UX31E", ALC269VB_FIXUP_ASUS_ZENBOOK),
    SND_PCI_QUIRK(0x1043, 0x14a1, "ASUS UX533FD", ALC294_FIXUP_ASUS_SPK),
+    SND_PCI_QUIRK(0x1043, 0x10a1, "ASUS UX391UA", ALC294_FIXUP_ASUS_SPK),
    SND_PCI_QUIRK(0x1043, 0x1517, "Asus Zenbook UX31A", ALC269VB_FIXUP_ASUS_ZENBOOK_UX31A),
    SND_PCI_QUIRK(0x1043, 0x16e3, "ASUS UX50", ALC269_FIXUP_STEREO_DMIC),
    SND_PCI_QUIRK(0x1043, 0x1a13, "Asus G73Jw", ALC269_FIXUP_ASUS_G73JW),

Build kernel

This command must be executed in top directory of linux source.

make -j `getconf _NPROCESSORS_ONLN` deb-pkg LOCALVERSION=-custom

Install new kernel and reboot

cd ..
sudo dpkg -i linux-headers-4.19.12-custom_4.19.12-custom-1_amd64.deb \
             linux-image-4.19.12-custom_4.19.12-custom-1_amd64.deb
reboot
| improve this answer | |
  • Hi Pawel! This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. – abu_bua Jul 21 '18 at 12:43
  • 1
    @abu_bua Installing a new and patched kernel does indeed solves it. What makes you think it does not? – DMT Jan 7 '19 at 9:41
1

A more comfortable way is to install the Ubuntu Kernel Update Utility (UKUU) and upgrade to the v5.0-rc1 kernel. The stable v4.20 doesn't include the fix for the Asus UX391UA, as described here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.