1

I'm running Ubuntu 16.04 on my Acer Aspire 7750G laptop with switchable graphics (integrated Intel graphics and an AMD Radeon HD 6650M). I recently bought an AOC Q3279VWF 2560x1440 monitor that I connected to the laptop through HDMI.

The largest possible resolution for the monitor under Display settings was 1920x1080. To force the native 2560x1440 I messed around with cvt and xrandr. Most refresh rates did not work (displayed an error in the terminal or no signal on the monitor) but when I by accident tried 44 Hz it suddenly worked:

cvt 2560 1440 44
xrandr --newmode "2560x1440_44.00"  222.75  2560 2720 2992 3424  1440 1443 1448 1479 -hsync +vsync
xrandr --addmode HDMI-1 "2560x1440_44.00"

However, while I get the correct resolution on the monitor, there is a constant terrible lag on everything that moves on the screen; when watching a video it is very stuttery; when moving the cursor it lags behind.


What is the reason for this lag and can it be fixed? Also, is there a logical pattern for which refresh rates work and which don't?

  • HDMI has many versions. Each version has a maximum bandwidth, which depends not only on the HDMI version but also on the specific kind of cable and connector used. See this nice table on Wikipedia for details on what resolutions and refresh rates are support by each HDMI version. Long story short, for 2560x1440 at 60 Hz you need at least HDMI 1.3. You may want to try 30 Hz instead of 44 Hz; it should work and may have a mitigating effect on the lag. – AlexP Jul 17 '18 at 12:46
  • @AlexP When I try to use 30 Hz the screen becomes black with a flash text saying Input not supported. 44 Hz is the only frame rate I've been able to get to work. – darksmurf Jul 17 '18 at 13:02
  • Ah, well then. Check that the HDMI version supported by the graphics card is at least 1.3, check that the cable is rated to support full resolution HDMI 1.3. – AlexP Jul 17 '18 at 13:05
  • My cable supports 1.5 and my Radeon GPU supports 1.4a. I am unsure how the switchable graphics work, but I can only guess that external screens run through the dedicated GPU. – darksmurf Jul 17 '18 at 13:18
  • Can you disable the Intel graphics from the BIOS? – AlexP Jul 17 '18 at 13:20
0

After reading this article on Medium I downloaded umc which I used with the --rbt option to generate the mode line instead of cvt. I adjusted the frame rate to get close to the same pixel clock that was used when it was working (but stuttering) which was 222.75.

This lead me to use

> umc 2560 1440 55 --rbt

# 2560x1440x54.97 @ 81.250kHz
Modeline "2560x1440x54.97"  221.000000  2560 2608 2640 2720  1440 1443 1447 1478  +HSync -VSync

that has a pixel clock of 221.00.

After adding this mode it worked like a charm, with the correct resolution and without any lag or stutter.

The whole process and solution seemed kind of random though...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.