0

I was trying to make a preseeded ubuntu-16.04-server-amd64 install on my KVM. Though the standard server iso install worked perfectly fine but, after preseeding, the vm hangs on the first boot due to:

intel_rapl: no valid rapl domains found in package 0

After this, I tried to install it on VirtualBox, though the error is same, the vm booted and I was able to login successfully.

0

intel_rapl is a power management related driver which makes no sense to load in a virtual guest anyway.

It was changed to no more show up in common configs just a bit after 16.04 kernels were taken in this commit

I'd most likely assume that it has nothing to do with your hang, but just happens to be the last message before the hang occurs for other reasons.

If you want to be sure you might mount your guest disk on the host and disable the module and then update the initramfs as well, like:

$ echo 'blacklist intel_rapl' >> /etc/modprobe.d/modprobe.conf
$ sudo update-initramfs -u

That should make your guest no more load it, but then probably still run in the - assumed to be unrelated - hang.

FYI - There was a similar discussion on the same around VirtualBox a while back.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.