10

I recently decided to install Ubuntu 18.04 on an old computer of mine (HP Pavilion G6) and everything went smoothly until the computer restarted.

Since my laptop is quite old, the monitor doesn't work, so I hooked up a second monitor to be able to use it. During the install, I was able to use the Fn+F4 shortcut to change my primary monitor, but after the computer rebooted, the shortcut stopped working, and the only thing I see is a purple screen.

So I really want to know if there is a way to switch monitors, and if not, how to login using only the keyboard because I'm basically blind. Thanks!

4
  • Maybe this will help. askubuntu.com/questions/760942/set-primary-monitor-on-16-04 Jul 16, 2018 at 23:01
  • I looked over the solutions they proposed, but none of them would work for me, since I would need to be logged in, and right now I can't.
    – Phoenixx
    Jul 17, 2018 at 5:25
  • Does pressing <super>p work (<super> is usually the key with Windows logo)?
    – pomsky
    Jul 17, 2018 at 13:54
  • No, it doesn't do anything
    – Phoenixx
    Jul 17, 2018 at 17:57

6 Answers 6

17

If you are meaning to switch multi-monitor mode (internal only, external only, join, mirror), you can do it with the keyboard shortcut Super+P.

I think it is very handy and useful, but it is not available under the GNOME Keyboard Shortcuts settings.

Note: The Super key can usually be found on the bottom-left of your keyboard, next to the Alt key, and usually has the Windows logo on it. It is sometimes called the Windows key or system key.

2
  • 1
    Thanks. This is just what I needed to get my display back to my laptop primary, since I normally have it on external only when on usb-c and didn't want to walk to the monitor with and futz. Gracias.
    – spazm
    Apr 15, 2021 at 6:24
  • 1
    I just discovered the Super+P shortcut by accident, and spent several minutes restoring the display configuration to how it was before (I have an external monitor atop my laptop display, rotated to be in portrait mode). For those in a similar situation, there are ways to disable the Super+P shortcut — see here: askubuntu.com/q/68463/23900.
    – waldyrious
    Jun 21, 2023 at 16:31
3

I finally found a solution.

After trying everything I could think of, I decided to take a completely different approach. I completely disassembled my computer, and found the problem with my computer screen (The screen was unplugged from the main board). So I fixed it, reassembled my computer and started it back up. Everything worked perfectly, I was able to log in and use it normally.

1
  • amanzing! never thought this end
    – Sherry869
    Feb 18, 2021 at 11:28
2

Okay I didn't solve the problem, but I got somewhere.

I managed to access the terminal using Ctrl+Alt+F2 which displayed normally on my external monitor and then logging in.

After that I used Ctrl+Alt+F1 to put away the terminal but it went back to the same purple screen. I have no idea if the other screen is still on the login page or if it's the desktop.

Then I went back into the terminal and tried a solution I found that seemed appropriate, that is the commands in the question here. Unfortunately, this didn't work giving the error message "Can't open display". The command xrandr --listmonitors gives the same error message. I tried to research this problem but nothing has worked so far, how do I get around this ?

1

You were not able to use the shortcut you used earlier in testing mode because you had not logged in once the installed system booted up. It is not a big deal to log in blind. Just press enter once and type your password and press enter again. You will see your empty purple screen (from your external monitor) to react to login somehow (probably the screen will become blac for a second or so). Once you know that you are logged in, use a shortcut such as super + p, or right click on you screen and then go to display settings to set it to display in your external display only.

1

This is maybe slightly out of topic, but in case anyone else stumbles here because they want to find a way to disable/edit the shortcuts for switching the monitor configuration (super+p, which @ aotherix mentioned), then here's how:

Install dconf-editor and search for switch-monitor, at least on my system the full path for this config is: /org/gnome/mutter/keybindings/switch-monitor. There you can edit the values.

0

In my case I installed lubuntu, but maybe it can work for you with a few tweaks. Go to terminal by pressing Ctrl+alt+F2 Login Install a Gui xrandr configurator in my case lxrandr sudo apt install lxrandr

Now export your display id export DISPLAY=:0

Run the configurator lxrandr

Go back to the desktop, it should be there waiting for you

Disable the primary output.

You're done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .