1

This question isn't a duplicate of Ubuntu 16.10 Dual Boot error - 'grub-efi-amd64-signed' package failed to install. The question is exactly the same because the error is the same but it has a different solution.


Never had problems installing Ubuntu. I already installed Ubuntu on this machine before but on a hard disk. However, this is the first time trying to install it on an SSD. The first thing that seems wrong is that the installer doesn't recognize current OS. So I shrank my windows 10 partition using windows and then tried to install Ubuntu on the free space created. Almost at the end of the process, it gives me the error:

The 'grub-efi-amd64-signed' package failed to install into / target/. Without the GRUB boot loader, the installed system will not boot.

The bootable USB with Ubuntu Live boots only with CSM disabled.

If you need other information to figure out what's happening, ask in the comment section and I'll edit the post to provide it. Keep in mind that I cannot use Windows anymore now.


I followed some of the suggestion in the post linked in the comment but boot-repair doesn't work. This is the log of boot-repair (sorry for the external link but it-s too long to post here).


As said in the comments, Windows is in BIOS boot mode. I created the bootable USB with rufus with the MBR (in theory should work with both BIOS and UEFI). However the bootable USB boot only with CSM disabled. With CSM enabled the error is:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi: Not Found
Failed to start MokManager: Not Found

I found no way to use the bootable usb with CSM enabled so I decided to change the way Windows boots from MBR to GPT with mbr2gpt. It seems that all went well. However, now I'm not able to boot with the bootable USB neither with CSM enabled nor disabled.

  • LInk above may help, if not post link to summary report from Boot-Repair. help.ubuntu.com/community/Boot-Info Is Windows UEFI. And then is new SSD seen as sda? Report should tell that info. Also what brand/model system? – oldfred Jul 16 '18 at 19:13
  • @oldfred I added the summary report in the question. It's a bit embarrassing but I don't remember if I installed windows with UEFI. The SSD is seen as sda in the ubuntu installer. What you mean by brand/model? If you are referring to the mother board is ASUS X550VX. – gvgramazio Jul 16 '18 at 19:41
  • Just a fun fact. Do you know those films and books where there is a guy that is working on a thesis and the only good enough PC in the house with all the data has a problem and stop working? I'm one of those guys. – gvgramazio Jul 16 '18 at 19:47
  • You show you booted Ubuntu live installer in UEFI boot mode. But Windows & Ubuntu are in BIOS boot mode. You have to be consistent, since only one drive shown with MBR(msdos( partitioning. Reboot live installer in BIOS/CSM/Legacy mode, not UEFI and rerun Boot-Repair. It does look like default repair will install BIOS boot version of grub, though. If you have valuable data, I would mount partition(s) and backup that up before doing anything else. Hard drives fail and sometime fail totally. If data is valuable you have backups & more than one backup. I have data on 3 computers & 2 locations. – oldfred Jul 16 '18 at 21:02
  • @oldfred, Yes, you're right, I was able to figure that out just a minute ago and I was going to edit the post. However I don't know how to tun the bootable USB with CSM enabled. Right now I'm using rufus to create the bootable USB with MSR. However it doesn't boot with CSM enabled. – gvgramazio Jul 16 '18 at 21:21
1

Thanks to oldfred for helping me. In the end, my problem was that I have installed Windows in Legacy mode and it was impossible (for me) to install Ubuntu in Legacy mode too. I converted Windows from Legacy to UEFI following this guide from intel. Basically open on windows a prompt command with administrator privileges and run

mbr2gpt.exe /convert /allowfullOS

Note that all the partition in the disk should have a MBR otherwise mbr2gpt fails. After that, all the partition have now a GPT. Restart and set in the BIOS and disable CSM. Then restart again and boot from the USB the Ubuntu Live version and proceed as usual. Note that the bootable USB should have a GPT. Note also that in some occasions you need to disable secure boot.

0

I faced the same problem, but my situation is a bit different. My HDD was causing a problem; even booting from live USB slowed down system, probably because it tried to use the swap partition (there was HDD light blinking).

So, I removed my HDD, tried to install Linux Mint 18.3 in a 16GB USB Flash drive, which I previously used to save timeshift images for Linux Mint 19 Cinnamon Tara. I went on to the default setup, chose the first choice, Delete everything from the Disk and install default option.

Then I got the message

grub-efi-amd64-signed package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.'

So, I checked the drive, there were 3 partitions, Efi setup (Fat32) (500 MB, then 200 MB Root (ext4) and Swap area. I deleted all the partitions, made it raw, reinstalled Linux Mint 18.3, but the same problem.

I manually created partitions, 500 MB for /dos, swap area 3.7 GB, rest is root. It said there must be an EFI partition to boot, BUT the bootloader can be installed in other drives too.

That gave me the idea to install WITHOUT EFI partition. I created a root partition of 10GB, SWAP of 3789 MB (for my 3.7 GB RAM), the rest for /home. It alerted me that there should be an EFI partition, I ignored, then another alert that if I install UEFI system on a BIOS machine, other OS might not boot. I ignored this also. And surprisingly, I installed the system successfully yesterday. It also hibernates and updated to latest packages.

  • Lucky that it worked for you. I think if the system had no option to boot in legacy mode, this could have made it unbootable and maybe difficult to fix. – Zanna Oct 25 '18 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.