1

I tried to save my PGP public key on keyserver.ubuntu.com, but it didn't work.

I tried to save from the console and a web form. When I save from the web form, I get the error - Unexpected POST request. When I save from console, I don't have any errors.

I tried to create a PGP key from Ubuntu default program "Password and keys" and sync to server, that also didn't work.

closed as unclear what you're asking by David Foerster, Elder Geek, Eric Carvalho, Thomas, N0rbert Jul 22 '18 at 12:15

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to Ask Ubuntu! Could you please add a little more detail? What exactly did you do, what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster Jul 16 '18 at 18:09
  • 1
    This is most likely an issue with the Ubuntu keyserver. I got the same error. I later tried keyserver.opensuse.org instead and it worked. – ace Jul 17 '18 at 12:12
  • 1
    @DavidFoerster OP actually had posted all the relevant information. "Unexpected POST request" is literally all that the browser displays when trying to use the Ubuntu keyserver web interface, and doing it via gpg does silently fail. – ace Jul 17 '18 at 14:08
  • @ace: I'm aware of that much. The missing piece is the (gpg?) command used to store the key file. – David Foerster Jul 17 '18 at 15:19
1

Looks like it is a temporary issue with keyserver.ubuntu.com itself. I couldn't upload my PGP keys to it for a couple of days either. And currently, the signing key for a newly created PPA is not showing up there although more than four hours has already passed since the PPA creation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.