I recently purchased an HP Pavilion g7-1310us notebook with the intention of doing a full install of the latest version of Ubuntu on it. I succeeded in installing Ubuntu 11.10 64-bit, but not without difficulties.

I couldn't find any guides for this new generation of HP laptops, so I'm posting this to aid others.

  • Oops. "Users with less than 100 reputation can't answer their own question for 8 hours after asking. You may self-answer in 7 hours." I'll be back later to post my solution.
    – klenwell
    Feb 19, 2012 at 17:45
  • In meantime, a draft of my answer can be found here: link
    – klenwell
    Feb 19, 2012 at 18:10
  • I also just bought a G7 1310us and had the same problems. After googleing for a solution I found that you can use the f2 and f3 keys to change the screen brightness (lost the link). You can also create a script to set the brightness at startup, etc.(sorry, also lost this link). Now I am trying to tackle an issue regarding very slow and poor wifi reception...
    – user48678
    Mar 1, 2012 at 5:39

3 Answers 3


Happily the answer is: Yes!

The main obstacle to loading Ubuntu 11.10 on the g7 is the video card. There is not a driver for the Intel video card. More information on the issue can be found here:


NOTE: I was informed on the Ubuntu IRC channel that this issue may not affect Ubuntu 10.04 LTS. So if you'd prefer an install that just works, you might try installing that version.

If you simply run the install CD for 11.10, you may end up with a dark screen that is virtually unreadable. To workaround this, these are the steps I followed:

Part I: Installation

  1. Download Ubuntu 11.10 64-bit version and burn to a CD. If you're familiar with IRC and have a second computer, I'd also recommend logging into the Ubuntu IRC channel in the event unexpected difficulties arise. It helped me.
  2. With the Install CD in the DVD player, restart the machine. Hit F9 to change the boot order and boot from CD
  3. When the CD boots, a purple screen with a keyboard logo at the bottom will appear. Hit any key to get to the install menu
  4. Hit F6, down-arrow to the nomodeset option and hit spacebar. An x will appear next to it indicating you have selected it.
  5. Select Install Ubuntu from the main menu and proceed with install. This took me about 30 minutes and went without incident.

Part II: Reboot

Once the installation is complete, you will be prompted to reboot your system. The nomodeset flag will not be set in your new install. You must interrupt the reboot to edit the bootloader and then, once the restart is complete, update the bootloader config file to avoid the dark screen issue. The changes are pretty simple. Follow these steps:

  1. As soon as the system boots, hold down the SHIFT key to get to the grub (boot) menu.
  2. Select default Ubuntu kernel at top and press E to edit the boot config file
  3. On the line near the bottom that begins "linux /boot" and includes "quiet splash", add at the end nomodeset
  4. Press ctrl-x to proceed

See the link here for screenshots: http://ubuntuforums.org/showthread.php?t=1613132 (I followed those directions but I've tried to clarify a couple points here that were frustratingly ambiguous when I first tried to follow them.)

Part III: Update Grub Config File

  1. Once you're logged in, open a terminal
  2. Make a backup of the grub file you'll be editing: sudo cp -v /etc/default/grub{,.bak}
  3. Edit the grub file: sudo gedit /etc/default/grub
  4. Change the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
  5. Save and close file
  6. Apply changes by running command: sudo update-grub

Again screenshots are available at the link in Part II.

Now restart your system. It should restart without issue. If you end up on a very faintly lit dark screen, do a hard reboot and follow the steps in Part II. Then double-check the steps in Part III and follow them again. (I forget to run sudo update-grub the first time.)

Since making these changes, I haven't noticed any screen issues or deterioration in the quality of my display. The only side-effect, as far as I can tell, is that when you choose Displays in the System Settings menu, it will say "Unknown" and all options will be grayed out.

Hopefully a driver will show up soon. More information on that topic can be found here:

[2-link limit exceeded: see askubuntu.com/a/95480/46766]

If you know of a better solution to this issue, please share it. (The one recommended in the link above -- using the ATI driver -- was strongly discouraged on the Ubuntu IRC channel.)


Answer from above helped me, but not entirely. After system I installed system, restart was needed. I waited, but nothing happened and I restarted laptop manually. After that, system booted, I heard the sound, but without display.

I entered console mode - Ctrl + Alt + F1, and console showed up. Then, I typed sudo apt-get install fglrx. The package was downloaded, installed and everything started working.

  • Just to clarify, you have a Pavilion g7-1310us? After installing fglrx, what do you see when you go to System Settings > Displays? ... Also, for those wondering (like me), fglrx is "a Linux binary-only driver for ATI graphic chips."
    – klenwell
    Feb 26, 2012 at 18:48

I'd like to add something to this very very helpful post.

After fighting with a Pavillion g7 laptop to get it to run 11.10, I had issues with it booting. It would hang while booting. I'd get this far:

Bad target number # (this error is repeated several times)

It's something to do with the AMD Video drivers, apparently. After spending some time finding a solution, this page solved my problems:


Go through the steps listed from "Before you start", down to "Generic Config" with only one change:

 $ sh ./amd-driver-installer-12-3-x86.x86_64.run --buildpkg Ubuntu/natty

needs to be changed to

  $ sh ./amd-driver-installer-12-3-x86.x86_64.run --buildpkg Ubuntu/oneiric

After going through this, I was able to boot to the desktop and finish Part 3 above. The laptop works great now.

I hope this helps anyone else having troubles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.