I've recently had a problem where my cpu was running at min speed constantly. This resulted in a very slow laptop and I found an article where one said it could be solved with this command:

this is the command I executed:

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

link to the thread: Cant disable permanently power management on WiFi

After doing so, my cpu now runs at a max freq of 3500MHz instead of the standard 2500MHz. This results in overheating and I'd like to reset the max freq back to standards. Any idea how? I've tried resetting in BIOS but unsuccesfully.



This reverts your change:

sudo sed -i 's/wifi.powersave = 2/wifi.powersave = 3/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

What you did was edit the file /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and search (the s/../) for wifi.powersave = 3 and then replace it (the /.../ after the s/..) with wifi.powersave = 2 so all that needs to be done is switch the search and replace parameter.

This edit has nothing to do with CPU frequencies though.

WiFi Powersave is a feature that allows a device to suspend its radio activity after a fixed period of inactivity. The device remains idle for a fixed time, usualy about 100ms, and once it is reached it wakes up to check if the infrastructure has any packets queued up for it.

wifi.powersave can have the following value:

NM_SETTING_WIRELESS_POWERSAVE_IGNORE (1): don't touch existing setting

Regarding CPU frequenty. Maybe you also edited /etc/default/cpufrequtils. Check if it exists and if so what is set for GOVERNOR.It should be one of: userspace conservative powersave ondemand performance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.