10

I bought a rtl8811au chipest based usb wifi for my work stationd that supports dual band. But when I plugged in the usb my ubuntu doesn't recognized it. So I had to find the driver and compiled it 'cause the one inside the usb package was not compatible with the last kernel version.

My experience with some drivers get from github platform was unsatisfied.

All the drivers I tested are an issue in my user experience. It seems that, with these drivers, my wifi usb stops working randomly, specially when the browser is open and it loads some javascript.

In that context the ping command works normally and all the other connections such as p2p like torrent, or app like telegram.

When that issue shows up, I have some options:

  • Waiting to work again with do nothing
  • Unplug and replug the usb dongle
  • Restart network service or turn off and turn on wifi

With all these options I have to wait and it is so heartbreaking !

So I think that the problem is relative to the driver 'cause I get it from github and it can contain some error.

I tried drivers like:

and the problem still persists on all these drivers.

Do you know some driver that works properly ?

9

Looking arch wiki they mentioned the chipset rtl8811au and they suggest a packet for its drivers.

sudo apt install dkms
git clone https://github.com/zebulon2/rtl8812au.git
cd ./rtl8812au
sudo ./dkms-install.sh 

So fallowing these command you can install the full working driver and get your rtl8811au wifi dongle works without issues !

| improve this answer | |
5

For Kernel version 5 and above use this repo

Follow the instructions in the readme it's really easy!

To sum things up:

git clone https://github.com/gnab/rtl8812au.git
cd ./rtl8812au
make

Check if the driver compiled properly and works:

sudo insmod 8812au.ko

Install:

sudo cp 8812au.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
sudo depmod
| improve this answer | |
  • This version of the driver for the 8811au chipset is better than others in my opinion , and you can install it by using dkms for an automatic reinstall at every kernel upgrade. – Bob91 Sep 30 '19 at 15:34
  • Thanks! Worked for NETIS WF2180 and 5.3.0-28 kernel on Ubuntu 18.04.3. Have compiled it instead of rtl8812au-dkms package which has stop work on 5.3.0-26... Try 'sudo apt purge rtl8812au-dkms; sudo rmmod 8812au.ko' in this case before compile from source. – Aleksey Deryagin Jan 28 at 19:06
  • 1
    hmm, the git clone for this just keeps asking for authentication, not sure why – DPS Feb 26 at 0:42
  • 2
    Interesting, maybe he made it private – yurikleb Mar 8 at 9:44
  • Yup, 404 on that repo now :-( – Jordan Rieger Apr 20 at 2:41
2

The easiest way is to install the driver from official Ubuntu repos by:

sudo apt install rtl8812au-dkms
| improve this answer | |
  • I remember that I tried it, but if I come here I think that it does not work properly – Bob91 Jul 15 '18 at 10:32
  • It is the same driver. Maybe it didn't build on some distro/kernel combination, but this is the conventional way that works in most cases. You didn't give information regarding your system, so... – Pilot6 Jul 15 '18 at 10:35
  • ubuntu 18.04 kernel 4.15.0-24 – Bob91 Jul 17 '18 at 15:45
  • Just tried it, it's not the correct driver for my hardware: Bus 001 Device 009: ID 0bda:b812 Realtek Semiconductor Corp. Device Descriptor: bLength 18 bDescriptorType 1 bcdUSB 2.10 bMaxPacketSize0 64 idVendor 0x0bda Realtek Semiconductor Corp. idProduct 0xb812 bcdDevice 2.10 iManufacturer 1 Realtek iProduct 2 USB3.0 802.11ac 1200M Adapter iSerial 3 123456 – Avio Jul 20 '19 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.