26

I don't know if this has been solved or not, and I didn't see it. I'm a complete noob to Ubuntu Budgie and I have 18.04 LTS with the latest updates.

I have Dropbox, Mega, and a few other things installed that are not showing in the System Tray at any point. Dropbox did for a little bit, but then it's gone. Mega, Thunderbird, qBittorrent, don't show up at all. pCloud and Skype show up right now, also when I turn on Franz it shows up.

Can someone please help? I'm sure this has been solved before but I'm not sure what's going on.

  • 1
    on simple Ubuntu 18.04.1 I just logged out and switched to Ubuntu on Wayland and than everything worked as expected in tray. Maybe this helps someone else. – fuser Sep 2 '18 at 15:21
18

This problem is common for both Ubuntu 18.04 and Ubuntu Budgie 18.04.

The reason of issue is lack of the libgtk2-appindicator-perl package in main Ubuntu 18.04 repository. A workaround is to install libappindicator-dev:

sudo apt install libappindicator-dev

and Gtk2::AppIndicator perl extension:

sudo cpan -i Gtk2::AppIndicator

Restart your applications, now all of missing icons have to appear in system tray.

| improve this answer | |
  • Here is the ubuntu bug bugs.launchpad.net/ubuntu/+source/shutter/+bug/1768032 – Étienne Sep 7 '18 at 12:22
  • 4
    This solved the problem once but the icons disappeared after rebooting. – dmishra Oct 22 '18 at 9:07
  • 1
    it does not work for me. Neither the dropbox, nor the variety's icon appeared in the system tray. I tested it with Ubuntu 18.04 and Debian 9 with same result. – Zoltán Süle Dec 20 '18 at 22:26
  • 1
    It does not work on Linux Mint 19.1 issue :( – kokbira Feb 12 '19 at 20:03
  • 2
    Wow, couple of commands that started half an hour rebuilding of something... and don't seem to have worked. – jayarjo Mar 8 '19 at 8:48
13

Here is the bug in Launchpad:

https://bugs.launchpad.net/ubuntu/+source/gnome-shell-extension-appindicator/+bug/1795121

It says 18.10, but I see exactly the same thing in 18.04. The workaround described in this works: Alt+F2, r, Enter (restarting the window manager).

An update to this: the issue was fixed and the fix released a while ago now. I haven't had the issue reoccur since.

| improve this answer | |
  • What's that command prompt that Alt+F2 brings up? – jayarjo Mar 8 '19 at 8:46
  • 1
    This worked, and didn't require a reboot like the accepted solution. – Étienne Mar 12 '19 at 12:32
  • 1
    @jayarjo it's literally a command prompt. You can type commands in it (and a couple of secret shortcuts like 'r'.) – Robin Sheat May 28 '19 at 13:18
4

Using budgie settings ensure you have the appindicator applet added to your panel.

A few applications show their panel icons as application indicator and not as a traditional system tray icon.

| improve this answer | |
1

You could launch budgie desktop settings from terminal:

$ budgie-desktop-settings

This settings manager is inside of budgie-desktop package. You could find all related packages by invoking a command:

$ apt-cache search budgie-desktop

To add what you want go to Top Panel section, click the Add applet 'plus' button and choose what you need. Bugie Desktop Settings applet adding to panel picture

| improve this answer | |
0

(I could not comment @fossfreedom's answer)

His tip solved the issue for me, but I had to install a package manually before. So, if you are using "vanilla" Ubuntu 18.04 or 18.10 with Budgie Desktop, assert that the AppIndicator Applet is installed. If not:

  1. Install the package budgie-indicator-applet
  2. Restart the session
  3. Add the AppIndicator Applet to the panel (preferably, right next to System Tray)

If you have any open application that uses it (ex.: Dropbox), the icon should show up.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.