2

Things I've already tried:

1. install all of this:

sudo apt-get install libblas3gf
sudo apt-get install libblas-doc
sudo apt-get install libblas-dev
sudo apt-get install liblapack3gf
sudo apt-get install liblapack-doc
sudo apt-get install liblapack-dev

And none of them were installed. I've receive this error message all the time

E: Unable to locate package X

2. Installing this

sudo apt-get install libblas-dev liblapack-dev

Also with an error message:

Package liblapack-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

Package libblas-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libblas-dev' has no installation candidate E: Package 'liblapack-dev' has no installation candidate

3. Trying to update my system and after that following the same steps as before again.

sudo apt-get update

But nothing had changed... Everything was staying exactly the same.

4. Trying to install like this:

sudo apt-get install libatlas-base-dev

And of course again is not working and I get an error which sound like this

E: Unable to locate package libatlas-base-dev

My system:

I'm using Kubunut 18.04

I was thinking that maybe is missing some repository and I don't know but how I can see it here is not.

Does any of you have any idea how can I fix this problem? If so, please let me know.

Output of apt-cache policy libatlas-base-dev liblapack-dev (after sudo add-apt-repository universe, sudo add-apt-repository main, sudo apt-get update)

libatlas-base-dev:
  Installed: (none)
  Candidate: 3.10.3-5
  Version table:
     3.10.3-5 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
liblapack-dev:
  Installed: (none)
  Candidate: 3.7.1-4ubuntu1
  Version table:
     3.7.1-4ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
  • It seems that you do not have universe repository. Lapack is in main. Try to add them with sudo add-apt-repository universe, sudo add-apt-repository main, sudo apt-get update and then add output of apt-cache policy libatlas-base-dev liblapack-dev to the question. – N0rbert Jul 14 '18 at 21:09
3

It seems that you do not have universe repository (for libatlas-base-dev). LAPACK and BLAS are in main. You should have both repositories enabled.

Try to add the repositories with

sudo add-apt-repository universe
sudo add-apt-repository main
sudo apt-get update 

And then install needed packages with

sudo apt-get install libatlas-base-dev liblapack-dev libblas-dev

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.