66

I want to disable the Super key, when I press Super nothing should happen.

How can I do that?

  • The "Super" key (a.k.a. "Windows" key) acts like a meta key such as Ctrl and Alt. In Unity, it's supposed to open the Launcher. To open the applications menu, use Alt + F1. I've no idea how to disable it though. – Lekensteyn Feb 19 '12 at 12:10
  • See askubuntu.com/a/1039164/587882 to disable the super key for the launcher. – Anthony Ebert Mar 31 at 1:24
71

You can change that in Compiz.

  1. Install compizconfig-settings-manager

    sudo apt-get install compizconfig-settings-manager
    
  2. Hit Alt+F2, type about:config and hit Enter to open the Unity configuration.

    Or run ccsm on the command line.

  3. Change or disable the shortcut for Key to show the launcher as you like to free your Super key:

    enter image description here

enter image description here

enter image description here

| improve this answer | |
  • The tab layout is different now (in 13.04), but you click around you can still find the Launcher setting, and it still works. This is a blessing for Emacs users. – user100464 Aug 6 '13 at 14:32
  • This does not work anymore. I have no idea why but it appears like there is no way to disable the "Super" key showing the "search bar" in Ubuntu anymore (if there ever was a way). I've tried literally everything. – Mike May 5 '15 at 23:35
  • @Mike, it works for me (Ubuntu 15.04), it's like user100464 said, it's just in a different location – david-hoze Sep 7 '15 at 19:48
  • 3
    Works for me Ubuntu 15.10. The new location is "Ubuntu Unity Plugin > Launcher" – Nathanael Weiss Jan 24 '16 at 6:39
  • 2
    In 18.04 ccsm's advanced search does not find anything for "launcher". – Nicolas Raoul May 18 '18 at 7:26
20

Execute the following command and then log in Unity desktop environment again.

dconf write /org/compiz/profiles/unity/plugins/unityshell/show-launcher '""'

In Ubuntu 12.04 and later:

gconftool-2 --set "/apps/compiz-1/plugins/unityshell/screen0/options/show_launcher" --type string ""
| improve this answer | |
  • This is great for those of us who don't want to have to install compiz-settings-manager! – Programster Jul 5 '13 at 21:04
  • Has the way keyboard shortcuts work changed between Ubuntu 12.04 and 14.04? – gonzobrains Jan 16 '15 at 19:33
  • 1
    On Ubuntu 14.04 (Trusty), I used gsettings set org.compiz.integrated show-hud "['']". – Mikel May 12 '15 at 23:43
  • 4
    The dconf write ... worked for me in 16.04. – mmoya Sep 1 '16 at 9:55
  • @mmoya checked on Ubuntu 16.10 - didn't work: dconf write.. – yetanothercoder Oct 3 '17 at 8:12
11

Just putting the following lines into your ~/.Xmodmap and then log out and log in Unity again.

keycode 133 = NoSymbol
keycode 134 = NoSymbol
| improve this answer | |
  • 1
    I suspect that would prevent the user from assigning that key to any other function. – Edward Falk Nov 12 '14 at 1:02
  • Which is just what I needed. I actually add NoSymbol multiple times on each line in order to suppress its use with other modifier keys. Thanks! – gonzobrains Jan 8 '15 at 23:25
  • Perfect. I was really struggling to find these keycodes. – maicher Mar 16 at 20:30
3

In Ubuntu 20.04, running this command works for me:

gsettings set org.gnome.mutter overlay-key ''

From https://ubuntuforums.org/showthread.php?t=2405352

| improve this answer | |
  • This is the only answer here that worked for me on Ubuntu 20.04. – Codex24 Oct 9 at 23:51
  • Use dconf-editor if you prefer a graphical tool to change the setting. I installed dconf-editor and changed org.gnome.mutter overlay-key from Super_L to Super_R and that solved my problems! – Viktor Kruglikov Oct 16 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.