8

I use an application called connectify to turn my laptop to a wifi router and provide other devices with internet using my DSL connection. But after I switched to Ubuntu 11.10 I can't use this any more. Is there any Linux software or trick available to do this?

5

yes, Ubuntu and many of it's flavors have feature called "ad-hoc network" and "wifi tethering"

To make wifie hotspot, you need to have some connection (cable connection, or another wifi connection (that woudl require a second wifi adapter).

Remember, you can't use the same adapter as WiFi receiver and wifi spot.

Go to network settings -> Edit Connections -> Wireless -> Add. Create a new connection and select Ad-hoc in Mode you can specify a password and enjoy.

  • last time I did, was not really fast though, but acceptable for browsing. – bakytn Feb 19 '12 at 10:03
  • Are these instructions complete? Don't you need to enable sharing as well? – Marius Gedminas Feb 19 '12 at 13:53
  • @MariusGedminas no you don't need.Ad-hoc means sharing – bakytn Feb 19 '12 at 14:04
  • 1
    You mean Network Manager automatically enables IP forwarding and sets up NAT as soon as you create an Ad-hoc connection? I didn't know that. (I'm not sure I believe it, either ;) – Marius Gedminas Feb 19 '12 at 15:43
  • 1
    @MariusGedminas yes! I worked like that already. I didn't set any routing, NAT or any forwarding, masquerades. – bakytn Feb 24 '12 at 4:13
3

there is bug currently in Ubuntu so there is work around for making ad hoc wifi access point, queting bellow:

"connecting with shared with other computers connection in NetworkManager. Other computer gets IP but NetworkManager disconnects the shared connection after half a second. This same setup worked perfectly fine in 11.04. Is there any fix, workaround or alternative way to share a connection with another computer over an Ethernet cable. (I can downgrade to 11.04 but I'd rather not ).

EDIT: found a workaround The workaround for now is to set IPv6 options to Ignore and then sudo killall dnsmasq. Reconnect and it should work."

I done it on my laptop with Ubuntu 12.04 and mine working fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.