2

I can see other questions about how to disable GNOME keyring for SVN. I have the opposite problem and cannot enable it. I can see answers for other distros, but they don't seem entirely to apply - e.g. there is mention of GNOME_KEYRING_SOCKET but I can't see any sign that it's set.

Here's data about my system and what I've tried:

  1. Ubuntu 18.04 LTS
  2. svn --version: 1.9.7 (r2800392), reports Gnome Keyring in list of credential caches
  3. ~/.subversion/config has [auth] password-stores = gnome-keyring
  4. ~/.subversion/servers has [global] store-passwords = yes
  5. ~/.subversion/servers has [global] store-plaintext-passwords = no and this setting is working, which indicates I am editing the right config file
  6. Gnome keyring daemon is running and works for both SSH and Evolution

Please can anyone suggest what I am missing or something else I can try?

3

I figured it out, inspired by a similar issue for an entirely different program.

Ubuntu 18.04 removed a default package that was present in earlier releases. The solution is to put that package back:

sudo aptitude install libgnome-keyring0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.