0

This question already has an answer here:

I tried Ubuntu 18.04, Budgie, and both have the same probelm when using nvidia dirver 390 & 396. When resume from suspend the system logout and every program I was working on is closed.

It seems that nvidia driver is not supporting any change I make on xorg.

When switch back to nouveau, the system works normally, and suspend resume is not logging out.

I have almost every solution on the web, including nvidia forum and SE, none of them works.

UPDATE: I reset recursively org.gnome using dconf-editor and now it works probably till now, it seems to be a gnome-shell problem

NEW

This problem is not a swap error, since I tried to turnoff the swap, in addition, I read the journal output, I is related to gnome-shell dealing with nvidia leads to kill the session when turning on the screen, or waking from sleep.

note: I know this question may be duplicated but for some reason I can't post any answer or put any comment.

Please Please If you realy know the answer share it otherwise don't comment any off topic comment

marked as duplicate by David Foerster, Eric Carvalho, Fabby, Kevin Bowen, K7AAY Jul 18 '18 at 20:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • There is a known issue, which can seem to happen a bit randomly, and has a workaround you can try. See Ubuntu 18.04 - logged out after resuming from suspend? , which was listed at the bottom of the Related list in the right-hand sidebar :) – sourcejedi Jul 15 '18 at 10:09
  • @sourcejedi it is not a swap error, I on of the attempts to solve the problem was when swap was disabled – user706142 Jul 17 '18 at 21:54
  • that bug can occur without swap. it's more usually in the code segment, which can always be paged out to disk. "Read-error on swap device" is not an essential part of the bug. I made sure to note in my answer, that "Read-error on swap device" message only occurs in a minority of occasions. I wrote a more customized answer on your question, but it was deleted since I'd effectively posted the same answer multiple times. There are two possible solutions in the answer which I commend to you. I really hope the accepted update will get released for Ubuntu within the next few weeks though. – sourcejedi Jul 17 '18 at 22:45
  • For me, open source driver nouveau always worked more perfect then stable version nvidia driver. Both for work and gaming. – Aravind Jul 18 '18 at 17:08
0

I was also having this problem plague me ... and a fix after many attempts was to re-install Ubuntu 18.04, and now it is working perfectly. I am also using Nvidia's "tested" Driver, as Nvidia was the culprit before.

Perhaps it was the "sudo add-apt-repository ppa:graphics-drivers" ppa which installed "Extra" Stuff from the PPA and/or the 396 driver itself which screwed up my laptop's hibernating ability.

Either way it works flawlessly at this time of writing with the NVidia's 390 tested driver.

It is/was definitely related to the NVidia driver as before switching to the Nouveau driver also worked, but I sure did not like that option.