3

I'm trying to install Ubuntu Server to my HP ProDesk 600 G3 SFF. Clean install. I've checked the SHA1 of the ISO. It's not corrupt. I've tried every combination of booting the system in every which way. I've tried both UNetbootin (doesn't recognize as having a disk, when run legacy, and immediately drops to grub shell when UEFI) and Multibootusb.org's (both the multiboot method and install to USB disk method (again, both legacy and UEFI for both options)) installer. Secure boot disabled the whole time.

So then I had the genius idea of taking the hard drive out, plug into another computer, booting a VM off of the installer ISO, and installing to the hard drive. Install succeeded, but the desktop "couldn't find an OS...etc". Which makes me think it's a compatibility/drivers/kernel modules issue, because there's also this error, when first booting:

[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0xb2 (or later)

I'm about ready to chroot the ISO and install intel-microcode because that has been the solution to the above error. (but that is an error that people are getting while their systems are up and running anyway...so...). I'll probably wait until someone more knowledgeable posts though...

The only other error that I can catch is a timeout waiting for the disk (probably related..?). And that hard drive is the only disk.

When trying to run the "Check disk for defects" boot option, it shows that error, goes to the purple Ubuntu splash screen with messages below the logo, and instantly reboots. When running the "Test memory" boot option, it says error: can't find command 'linux16'.

Note: When booting via multiboot USB, I can get into the installer no problem, but it fails during the install process every time. Always at:

...
  configuring installed system
    running 'curtin curthooks'
      curtin command curthooks
        configuring apt configuring apt
    

Going to full log has these errors (bear with me, manually typing them and choosing what I think will be important)

Running command ['unshare', '--fork', '--pid', '--', 'chroot', '/target', 'lsb_release', '--all']
Unable to get lsb_release --all: unexpected error while running command - blah blah : error code 127
Stderr: chroot: failed to run command 'lsb_release': No such file or directory
Running command ['unshare', '--fork', '--pid', '--', 'chroot', '/target', 'dpkg', '--pring-architecture']
Stderr: chroot: failed to run command 'dpkg': No such file or directory : blahblah : exitcode 127
Does some more 'Running commands' that succeed
Does some more 'Run commands' that error out because can't find files: error code 127

Would post full logs, but I can't seem to drop to shell...

Any help would be greatly appreciated. I've been working on this for about 5 hours straight now -_-

Fyi, not too great in Linux environment. I can get around a little, and cause havoc, but that's it. I'm a windows sysadmin.. :)

0

I had the same error. Burnt a DVD and it worked. NO clue why. I fought for half a day. Same error messages you mentions. Then gave up on USB install.

4
  • Interesting. Thankfully, 18.04.1 was release a little after this post, and, for whatever reason, it work when booting from USB (most of the time). Occasionally, it would still error out with the same messages, though...
    – J. Doe
    Aug 20 '18 at 18:53
  • I'm still getting this error. Same error code, installing 18.04.02. Unfortunately DVD is not an option for me.
    – Josh
    Jun 21 '19 at 19:05
  • Same here, for some reason the live USB method always has some problems, even though it should be the same
    – Mattia
    Jul 19 '20 at 16:11
  • It will work with other installers. Try Rufus and or Universal USB Installer. Jul 20 '20 at 0:03
-1

My Ubuntu 64-bit dual-boot installation by USB portable ISO drive had failed To install. I had 100 GB allocated for the latest version, but then the installation ran into an error.

Version 20.04.1 64-bit.

I even tried the Universal USB Installer and the USB drive would not appear in the boot menu.

So why not try using a virtual machine within Oracle VirtualBox?

I tried that and plan C works.

1
  • 2
    Running a server in VirtualBox will not give the server full access to all the physical hardware resources of the computer.
    – karel
    Sep 23 '20 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.