1

I've been trying unsuccessfully to do a fresh install of Ubuntu 18.04 onto a blank Crucial MX500 SSD. The computer is a Lenovo Ideapad 300 with 8Gb memory.

When I reach the Installation Type page I only see the "Other" option, not the normal options to erase the old OS, install alongside or erase the disk. I try to format the disk, I enter the details for an ext4 partition filling the whole disk. (I don't think I need a swap partition in this version.) When I move on to the timezone selection page I get "The ex4 file system creation in partition #1 of SCSI5 (0,0,0) (sda) failed." and I'm flipped back to the disk page. I've looked in system logs but nothing seems to help.

I've tried formatting using fdisk and gparted with mixed results, fdisk seems to recognise the ext4 partition but gparted thinks it's an ISO9660 (cdrom). In any case the installer requires me to reformat to set the mount point.

(Note - I have successfully installed 18.04 onto other HDDs without any problems, but wanted to use SSD to improve performance.)

Has anyone successfully installed 18.04 on a Crucial MX500? Thanks in advance for any help.

3
  • (I don't think I need a swap partition in this version.) Correct. – K7AAY Jul 12 '18 at 22:03
  • 4
    With SSD interface, your machine should be able to see the drive like regular HDD. Douple check that you don't have drive interface set to RAID i nthe BIOS, use AHCI instead. – Bernard Wei Jul 12 '18 at 22:04
  • I agree with @BernardWei and definitely check the interface for the drive. Also, that is very much an opinionated argument about whether a SWAP is needed or not. Depends on what you are going to do with the system. If you plan on hibernation, then yes, swap is needed in this case. And I am certain that there are other reasons for needing it. If you're worried about SWAP increasing the amount of writes to the drive, don't worry, it doesn't unless you don't have enough RAM in your system and it is constantly swapping. Look into the swappiness settings. – Terrance Jul 12 '18 at 23:47
0

Thanks to all who responded; after much messing about I've fixed it.

I spent some time with fdisk and (g)parted trying to see what was going on, then discovered, after deleting all partitions, that the disk was still mountable - and contained a copy of the Ubuntu Live boot image. (I put this on there thinking it would be trivial to overwrite - seems not.) I eventually took the nuclear option and zeroed the whole of /dev/sdb on a USB port: # dd if=/dev/zero of=/dev/sdb running overnight. After that I could set up the partitions I wanted (and I have included swap so it can hibernate - thanks Terrance). It's now booting fine! Thanks again responders.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.