0

I was trying to install ubuntu on my laptop(which is old and doesn't support UEFI) and while installing, it showed this error message: "The 'grub-efi-amd64-signed' package failed to install target/".

I found the solution(here: https://askubuntu.com/a/1044751) and it solved the problem with the error, installation finished then the computer got restarted but ubuntu didn't started, to be clear nothing happened except that this page shows right after turning on the laptop: Bios setting problem

Now I can't even access my "bios settings" page neither using a bootable memory.

While I hit F2 during the hardware initialization the same page keeps showing. When I'm in the page and press Enter the page just loads again, what should I do?

8
  • There is no way for the operating system to affect the functioning of the BIOS menu. Provide more information about your hardware please?
    – Amith KK
    Jul 12, 2018 at 18:53
  • @AmithKK it's fujitsu AH532, Intel core i5 Sandy bridge CPU, and 12 GB of ram Jul 12, 2018 at 18:54
  • What happens when you press tab on the screen that comes up?
    – Amith KK
    Jul 12, 2018 at 18:58
  • @AmithKK it switches to "Application Menu" tab, there's one option "Diagnostic Screen" Jul 12, 2018 at 19:01
  • 2
    Actually, the OS can change the BIOS. There was a bug filed bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147 that would corrupt the BIOS from 17.10
    – Terrance
    Jul 12, 2018 at 19:03

2 Answers 2

1

Upon looking up the Laptop Model on Google, several issues with your specific model of laptop losing BIOS usability(Albeit on windows installs) popped up

The solution seems to be unplugging the hard drive, which will allow the bios to work, going to "Advanced Settings" and disabling FastBoot

Source

1
  • I removed the hard disc and nothing changed, still the same page keeps showing. Jul 12, 2018 at 19:21
0

I've recently looked into fixing this issue, and came up with a consistent way of restoring the laptop to full operation.

The boot menu entries can be partially restored by bridging the "CL1_CL2" test point that is located under or next to the RAM slots. It may be required to have the laptop powered (or even powered on) while bridging the contacts for the test points to have any effect. This brings back the device-based boot menu entries, but does not yet restore access to the BIOS Setup menu. For that, a USB stick with Fujitsu's BIOS update tool (search by serial number to make sure you find the correct hardware revision) needs to be prepared, booted from, and run. This restores most BIOS settings to their default, including the missing BIOS Setup menu.

Alternatively, if the currently installed Linux system is still bootable (I know this doesn't apply to OP, but maybe others end up here and still have a bootable system), one can use this tool to restore all entries without having to go through a BIOS update and reset. This works by manually rewriting all broken EFI variables with their expected content. Please do make note of the list of supported configurations and of the disclaimer (and let me know in case the tool does or doesn't work on some previously untested configuration). In case you want to know more about this works, there is a post explaining the underlying details.

Lastly, a workaround for the issue has been merged into the Linux kernel, which should keep this from occurring on any new installations. This patch already ended up in the current installation media for the Ubuntu 24.04 beta (which I have confirmed to be not affected), and it will presumably be included in all installation media going forward.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .