0

I'm very new to Ubuntu and Linux. I've been trying all day to find a fix for steam to work but I keep getting the same error. Steam refuses to start when I run it using the icon on the desktop or the icon in the applications menu. When I type

steam

into the terminal I get this error:

Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

I haven't found a single thread with my problem, I keep finding people with AMD graphics cards that have driver issues but no luck with NVIDIA.

1

I have the same problem. You can fix it by removing your NVIDIA drivers and install them from their website (that worked for me, because it seems to be a newer version[390.44 -> 390.77]). This has been tested only under Linux Mint 19, which based on Ubuntu 18.04 - theoretically it works under Ubuntu too.

  1. Download the NVIDIA driver
  2. Remove NVIDIA:

    sudo apt remove nvidia-driver-390 -y
    
  3. Clean up:

    sudo apt autoremove -y
    
  4. Log out!
  5. Switch to console by pressing CTRL+ALT+F3
  6. Log in...
  7. Stop the display manager:

    sudo service gdm stop    #or lightdm
    
  8. cd Downloads (or wherever it is)
  9. Make the driver executable:

    chmod +x [driver package name]
    
  10. Run and install it (let it fix xserver settings AND libs!!!!):

    ./[driver package name]
    
  11. Enter: reboot
  12. Should work now!
  • 1
    Hi @Simonmicro ! Console on tty1 and lightdm sound like 16.04. Could you please clarify if the instructions are for 16.04 or 18.04 or maybe work on both? – danzel Jul 20 '18 at 15:40
  • It a solution for Linux Mint 19 - based on Ubuntu 18.04 bionic beaver ;) – Simonmicro Jul 21 '18 at 19:51
  • At least 3. and 5. are different in Ubuntu 18.04, so maybe you could indicate that the procedure was only tested on Linux Mint 19. – danzel Jul 21 '18 at 23:12
  • Okay, according to askubuntu.com/questions/979027/… you will need to press CTRL + ALT + F3 / F4 to open the console. And you must run sudo service gdm stop to kill the display manager. – Simonmicro Jul 24 '18 at 11:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.