I am using 11.10 (on Virtuabox) on a brand new Samsung Series 7 with switchable graphics, which I am assuming that could be part of the issue here.

The graphics card is integrated Intel / and an ATI 6750M with 1 gigabyte of VRAM. I have Virtualbox (on Windows 7) set to the Maximum Performance setting so that it always kicks on the ATI card. I have Virtualbox set to use 128 MB (the maximum) of VRAM.

Almost all of the graphics are slow, if I launch Terminal it will take 5 or 6 seconds to even launch. If I type into the terminal, it will take 5 seconds or so for the characters to appear.

Has anyone else had any issues with this?

  • Is it possible you're using an i5 or a processor with out the virtualization extensions? That'd cause it to be really slow. Edit: Nope, it's got Vt-x... Hmm, are the Vt-x extensions enabled in VirtualBox?
    – Chuck R
    Commented Feb 18, 2012 at 23:05
  • Githlar: Yes, the Vt-x extensions are enabled, as is PAE/NX. In some of my research I saw that it is recommended to enable those as well, but that did not help either. Also, the CPU is an i7 (quad core) at 2.2 gHz. I also have 6 gigs of RAM with about 1.8 gigs of RAM dedicated to the Ubuntu guest. I have also tried both 32 and 64 bit for the Ubuntu guest, neither being any different - they both do it. Commented Feb 18, 2012 at 23:12
  • 1
    It doesn't seem like a video problem unless you're getting mouse stutters or something. What display is emulated to VirtualBox just a VGA display or is it emulated as ATI as well?
    – Chuck R
    Commented Feb 18, 2012 at 23:15
  • I can't assume anything unless you can give us more info about the virtual machine.
    – maniat1k
    Commented Feb 23, 2012 at 0:11

2 Answers 2


After more research, it looks like the issue is (surprise, surprise) with the switchable graphics. Even after instructing Catalyst Control Center on Windows to always use the dedicated Radeon, it still uses the integrated Intel GPU. To say I am not happy with Samsung at the moment is a complete understatement.....I paid for a discrete GPU, now I can't use it? This is apparently a widespread problem.


I'm with a similar problem with no solution so long... I did not have any troubles on 11.04 but I had troubles installing the drivers for my Notebook GPU on 11.10 Oneiric Ocelot. I tried to install it many times and I don't know what I did but I got it to at least open the Catalyst Control Center... My Catalyst Control Center gives the option to switch from low performance power saving to high performance. The low performance is checked by default. When I check the high performance option, it says that the actions will take effect after rebooting the system. The problem is that I reboot the system and when I open the Catalyst Control Center again, the option did not change, it is still on the power saving GPU... I am not able to use the maximum performance of my computer's GPU : (

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .