2

When I plug in my headphones, the sound doesn't come out from them. They aren't detected in alsamixer.

sudo lspci -v | grep -A7 -i "audio"
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    Subsystem: Dell Sunrise Point-LP HD Audio
    Flags: bus master, fast devsel, latency 32, IRQ 139
    Memory at ef228000 (64-bit, non-prefetchable) [size=16K]
    Memory at ef200000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
Home directory not accessible: Permission denied
card 0: PCH [HDA Intel PCH], device 0: ALC3253 Analog [ALC3253 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Can someone help here on how can I make it work? Thanks

  • 1
    Check in PulseAudio, under the Output Devices tab. Built-In Audio Analog Stereo. Right there you could switch between the built-in speakers or the headphones. – user123492 Jul 11 '18 at 21:16
  • The only thing that is shown is Speakers I don't have any other option. – Ricardo Pinto Jul 12 '18 at 3:10
  • Codec: Realtek ALC3253 – Ricardo Pinto Jul 12 '18 at 3:21
2

Install and run hdajackretask:

sudo apt install alsa-tools-gui
sudo hdajackretask

Forcibly connect the headphone jack pins:

  1. Under Select a codec choose Realtek ALC3253
  2. Check the Show unconnected pins option
  3. Under Pin configuration iterate each pin:
    • Click the Override box
    • Click the drop-down list and choose Dock Headphone if it exists
    • If Dock Headphone is not in the list then uncheck Override
    • On the Dell E7389 you should override pins 0x16, 0x17 and 0x21.
    • Note the scrollbar to show the bottom of the list may be hard to notice.
  4. Click on Install boot override
  5. Reboot and it should work now
  • I just tried this on my Dell Precision 5510 running Ubuntu 18.10. To my surprise, it worked! Thanks! – Adam Dingle Feb 3 '19 at 15:35
  • Worked for me on a Latitude 7389 with Ubntu 19.10. Thanks so much! – Nathan Kidd Mar 31 '20 at 2:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.