Any time I try to install anything or run apt update, I get this error:

E: The repository 'http://ppa.launchpad.net/armagetronad-dev/ppa/ubuntu bionic Release' does not have a Release file. 
N: Updating from such a repository can't be done securely, and is therefore disabled by default. 
N: See apt-secure(8) manpage for repository creation and user configuration details.

I'm not skilled enough to figure this out. I've seen that I can try ppa purge but I don't know how.

  • 1
    sudo add-apt-repository -r ppa:<ppa to remove> – Kulfy Jul 11 '18 at 16:11
  • 2
    I just figured it out. I just had to go into Software & Updates Go into Other Software and uncheck the boxes with those links – Jeffrey Kratka Jul 11 '18 at 16:27
  • 2
    the PPA that you have added is not for Ubuntu 18.04 it supports releases up to 17.04 you have to remove that PPA for now unless maintainer will support 18.04 in future. Here's how to askubuntu.com/questions/307/how-can-ppas-be-removed – JoKeR Jul 11 '18 at 16:29
  • 1
    @JeffreyKratka that's the GUI method. Both methods are correct. – Kulfy Jul 11 '18 at 16:31

You can execute in your command line:

sudo apt-add-repository -r ppa:armagetronad-dev/ppa
sudo apt update -q

The first line remove the repo and the second line update list of packages. After that you can install new packages, update or remove them.

| improve this answer | |
  • 1
    q means quiet as seen here – Timo Jul 20 at 17:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.