I've have my Dell U2311H monitor working fine at 1920x1080x60hz using the DVI-D cable that came with it (18 pin, single-link).

When I try and attach a longer 5m cable which supports Dual-link (24 pins) the monitor doesn't work and displays the following message:

"The current input timing is not supported by the monitor display. Please change your input timing to 1920x1080@60Hz or any other monitor listed timing as per the monitor specifications."

Nothing else changes except the cable, rebooting doesn't help. As far as I understand, dual-link cables should be backwards compatible with single-link.

Weirdly, in nvidia-settings it says DFP-0 has "Connection link: Dual"

What could be causing this? Is there some way in xorg.conf to force it to single-link mode? There doesn't seem to be any option on the monitor other than selecting the DVI-D input.

Update: Since it seems to be the cable length causing the issue (see my answer below), is there a way to save the EDID info correctly returned with the short cable and force it to be used with the long cable?

  • Firstly, please confirm whether the monitor is supposed to support dual-link. If so, that would explain why nvidia-settings is reporting dual-link. – outofstep Oct 31 '10 at 12:47
  • How do I do that? It doesn't specify on the website. The monitor has a native resolution that single-link can handle, and came with a single-link cable. nvidia-settings is reporting that Dual connection link while it's using the single-link cable. – Tom Nov 1 '10 at 6:15

I looked on a supplier's site and found that they declare it as having dual-link. In which case it would seem that either your cable or monitor is faulty. Try contacting Dell?

If you wish to accept the status quo, then your original question remains unanswered.

Presumably you will need to defeat the EDID info being returned by the monitor. That's beyond me but I hesitantly suggest, lacking any other responses, that you generate the xorg.conf using nvidia-settings for the single-link cable and retain it for the dual-link. Failing that you could convert your dual-link cable to single-link, either by mutilation or by use of an adapter?

  • I don't think the xorg.conf file was changing when the dual-link cable was plugged in. There was no rebooting or resetting, all I did was swap the cables. – Tom Nov 2 '10 at 7:33

I've tried again with a shorter dual-link cable and it is fine, so it seems that it was the length of the cable causing the problem.

http://www.playtool.com/pages/dvitrouble/dvitrouble.html#shortercable seems to confirm that could be the culprit (maybe combined with a low-power signal generated by the graphics card.)

  • I'm very glad you fixed it but it is worrying that the combination of equipment, which was seemingly compliant with the DVI standard, didn't work. – outofstep Nov 2 '10 at 10:53
  • Update: I've now got it working perfectly with a 3m dual-link cable... – Tom Nov 17 '10 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.