We are trying to address a security issue with Ubuntu 17.10 image (ubuntu:17.10) which uses glibc version 2.26. This has a security vulnerability CVE-2018-10000 that is related to integer overflow.

Inspite of googling around, I wasn't able to find the updated Ubuntu image that fixes this issue.

Issue Link: https://www.cvedetails.com/cve-details.php?t=1&cve_id=CVE-2018-10000

  • 1
    The presently up to date stable Ubuntu version 18.04 comes with glibc 2.27. Is the issue fixed there? – Takkat Jul 11 '18 at 11:22
  • Your description of CVE-2018-10000 does not see to match the actual vulnerability. – user535733 Jul 11 '18 at 11:32
  • @Takkat We would like to use 17.10 version of Ubuntu. Is there a minor version of 17.10 with the fix? – Sid Jul 11 '18 at 11:41
  • 1
    @Sid: you probably will not want to continue using 17.10 in one weeks time. It will reach end of support by then. – Takkat Jul 11 '18 at 11:48

Each CVE is tracked as a Launchpad Bug with a predictable URL. Here's the Launchpad bug for that particular CVE:


This particular issue does not seem to affect any Ubuntu software, so no work is planned.

If you have further questions on Ubuntu Security, ask them here on AskUbuntu first. If you can show that the Ubuntu Security Team was demonstrably mistaken in an assessment, then contact them at #ubuntu-security or #ubuntu-hardened on Freenode IRC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.