3

I recently purchased a Asus TUF FX504GD laptop and want to install Ubuntu onto it.

I have updated the BIOS to the latest version and have disabled both fast boot and secure boot.

There is no dual-boot, this is just a simple Ubuntu only install.

Using a USB stick with Ubuntu 18.04 LTS, the installer loads properly, it finds both the 128GB NVME drive and the 1TB HDD.

The first time I tried to install, I chose to encrypt the root partition, the install completed and I restarted.

It booted into GRUB recovery. When I used the command ls on the boot partition (hd0,gpt1) it said unknown format. So I was unable to set the root and boot from GRUB.

I restarted the installer, this time without encryption and it resulted in the exact same thing.

Next, I decided to use the Try Ubuntu live distro and it worked perfectly, (except the track pad, I had to use a USB mouse).

So I used the install feature from the desktop. It installed everything, without encryption, and I restarted.

Ubuntu boots correctly and I am greeted with the login screen. I enter the password and nothing happens, it just sits there.

I press Alt+Ctrl+F3 and enter the terminal and I can log in without issue. I did a apt update + dist-upgrade and restarted and it was exactly the same.

After sitting logged in for a few minutes in tty3, lots of messages appeared. The first is as follows.

INFO: task kworker/1:0:17 blocked for more than 120 seconds
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disable this message.

I understand that this is a new model laptop, but if anyone has any info or help with getting this installation working, please let me know. Otherwise I'm going to have to return it.

  • I have the many problems with openSUSE Tumbleweed and Kernel 4.18rc8. If I use acpi_osi=! in Grub, the situation gets much better. All CPU works and temp is normal. The most FN keys works. – Erick Gabriel Aug 8 '18 at 2:47
  • Are you still have this issue – Dipak Nov 19 '18 at 12:54
2

I had a partially similar issue. For me the Ubuntu 18.04 LTS desktop installer hangs on boot always. I tried to boot with the server installer, it worked well, so I installed it. But for example rebooting, shutting down the machine was halted at a point, after the console said "Starting Reboot" it stopped with a "Protocol error" message. Also lspci went into an infinite loop, ate up a core on 100% and I got a message after some time that a process is hung for too long. I had to forcefully reboot the laptop to stop that process.

As a solution, which solved my problem is that I'm installed the Nvidia drivers from the ppa repository as described here: How to install the NVIDIA drivers on Ubuntu 18.04

After that and a reboot everything is started to work properly. Now I have to install X manually of course.

1

I also had problems with this laptop but with Manjaro. I'm going to give you some advises. First you're going to need version 4.17 of the kernel, previous versions don't work. Second you'll need the propietary Nvidia drivers. The installation that I used coupled Intel, Nvidia drivers and bumblebeed. It works great but the trackpad don't work, it may be solved in future kernels. Anyways I don't recommend you to return the computer just because it doesn't work properly right know, this kind of things take time.

Best regards

  • Thanks for your encouragement. I bought this laptop and now ubuntu is running smoothly on it except the trackpad – Jay Chakra Oct 13 '18 at 17:18
  • I found this laptop in a webshop in Finland and am about to order it I plan to use it mainly with Linux (Ubuntu18.04) for devevelopment and sone gaming (it has the Nvidia Geforce 1050ti aftet all) and will add an Nvme 250 GB SSD to it and configure it dual booting with the W10 that it has preibstalled in it in the hybrid 1 TB SSHD disk. Just wanted to know if it is the same device that you have been testing here, the product name is "ASUS Gaming FX504 15,6" codename "FX504GE-E4099T/R", cause I want to be sure that all its hw work from Linux too. – OpenITeX Nov 23 '18 at 22:04
1

Bought this laptop today and Ubuntu is working like charm after some initial hiccups.

It did stuck on the login screen. Which was resolved as follows.

  1. Shift to tty3 using ctrl + alt + f3
  2. Login to your user
  3. Configure Wifi Using nmcli
  4. Install Nvidia Drivers

Then upgraded the system to 16.04.2 then restarted the system and things are working fine.

I have created a dual boot system with the existing windows and another ubuntu 18.04 instance on the SSD.

Approach: * Shrunk the nvm partition that had windows to ~45 GB. Rest I have used for ubuntu.

Will keep on updating this post as I find any bugs/troubles using this system.

Here is the screen shot of the current running version

enter image description here

  • Hi Jay, thanks for your instructions on how to run Linux on this. I found this laptop in webshop in Finland & am about to order it, planning to use it with Ubuntu 18.04 for devevelopment and sone gaming (Nvidia Geforce 1050ti aftet all) and will add an Nvme 250 GB SSD to it and configure it dual booting with the W10 that it has preinstalled in the hybrid 1 TB SSHD disk. Just wanted to know if it is the same device that u have been testing here, the product name is "ASUS Gaming FX504 15,6" codename "FX504GE-E4099T/R", cause I want to be sure all hw work from Linux too. – OpenITeX Nov 23 '18 at 22:01
  • Hey, the codename is FX504GE-EN224T. You can get the full specification here flipkart.com/… – Jay Chakra Nov 27 '18 at 4:07
  • Though there is one problem. The touchpad is still not working after upgrading the kernel to v4.19.4. You will have to use external peripheral device – Jay Chakra Nov 27 '18 at 4:09
  • Just a suggestion. If you are considering to buy this laptop. Go for 505GE Version. The newer version has RGB keyboard. Source: flipkart.com/… – Jay Chakra Nov 27 '18 at 4:14

protected by Community Oct 25 '18 at 22:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.