Okay heres the problem.

On my desktop, I had windows 10. I put another SSD in there and installed Ubuntu on that. And when I booted the machine, Ubuntu loaded the boot loader and I could select the operating system I wanted to use, great.

Then I reinstalled Ubuntu because I got in a mess with my SQL server. But ever since then, the boot loader looks different. I lists Ubuntu at the top, and at the bottom instead of Windows Boot Manager (or something to that effect) it says Windows 7. When I select the Windows 7 I get a windows error message which basically says that it cannot load (I cannot remember the details of the error message, but it was large grey text on a DOS like screen).

So now I dont have the option to boot to windows, I have to do it manually from my BIOS which is a huge pain. How can I get this functionality back? I tried mounting the Windows Disk (by clicking on it and viewing the files) in Ubuntu and running os-probe, but that didnt seem to sort anything. The OS is there, so why can't I boot to it from the GRUB boot loader?

1 Answer 1


Normally a simple update-grub should be sufficient for detect windows loader and be able to dual boot systems.

  • yeah, i've tried os-prober, update-grub but it doesnt ever find the Win10 boot. It identifies a Win7 drive in /dev/sdd1 but as far as I know that doesnt exist.
    – Chud37
    Jul 11, 2018 at 9:23
  • It detects the windows 7 loader because use the same as windows 10, the called windows 7 loader should be the windows 10 entry. Just for info, have you update to grub2? If you have grub 2 try update-grub2 or grub2-mkconfig > /dev/null
    – WilliWonka
    Jul 11, 2018 at 9:29
  • @WillWonka I seem to have update-grub2 but not grub2-mkconfig. As I mentioned, when I run the Windows 7 loader from the boot menu i get a windows error. When I run from the Boot menu in the Bios on the correct hard drive I get windows running fine.
    – Chud37
    Jul 11, 2018 at 9:59
  • @Chud37 can you check if the 'secure boot option' on BIOS is active? If it's the case, desable it and try again.
    – WilliWonka
    Jul 11, 2018 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.