0

I followed a recent post from this site on how to setup an openVPN client on an Ubuntu machine. I have a PiHole and an openVPN server running on a RaspberryPi. I did

sudo apt-get install openvpn
sudo apt-get install network-manager-openvpn-gnome

I generated an openvpn client file on my Raspberry Pi and copied it over to my linux laptop via SSH. I then set-up in Network options. I went to VPN, clicked +, double clicked "import from file", navigated to the client's .ovpn file, double clicked "device.ovpn". It then jumped to the VPN set-up with all the fields autocompleted.

When I click VPN then connect, I get a padlock icon in the top right and the wired network icon.

enter image description here

This suggests that it's connected, but all website requests timeout. As soon as I turn off the VPN, all website requests work instantly. I know that the RPi, openVPN and PiHole are working because I have used them all together on my Windows laptop and my iPhone.

1

The tutorial you mention is not complete, it looks like there is no proper forwarding setup.

I suggest this DigitalOcean tutorial on OpenVPN setup. It is very detailed and works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.