0

Did a fresh install of 18.04 alongside Windows 10 (UEFI). Now my system boots only into grub2 commandline.

I am able to boot into both windows by executing

> chainloader (hd0,gpt1)/efi/Microsoft/bootmfgw.efi

and ubuntu by executing

> set prefix=(hd0,gpt6)/boot/grub

> set root=(hd0,gpt6)

> insmod linux

> insmod normal

> normal

I ran grub-install, boot repair several times after booting into ubuntu, but to no effect. I still keep booting into grub commandline.

Any help is appreciated. Boot repair pastebin - http://paste.ubuntu.com/p/64X9XmshBJ

Screenshot of gparted - enter image description here

Edit - ** tried these and did not work**:

  • grub-install with grub-efi-amd4

  • grub install from live usb

  • boot-repair from live usb or ubuntu

  • fresh install of 18.04 again lands in grub manual

  • once you are in Ubuntu with above commands, can you provide a pic after opening "GParted" – PRATAP Jul 10 '18 at 16:08
  • @PRATAP Screenshot of gparted drive.google.com/file/d/1dX_aCj9LK9bi8XuKO9SVLndlCUeOuaCL/… – jayendra.rakesh Jul 10 '18 at 16:15
  • also dump of one of the boot-repair attempts - paste.ubuntu.com/p/64X9XmshBJ – jayendra.rakesh Jul 10 '18 at 16:19
  • can you click on sda2 "red color alert" and paste the error? – PRATAP Jul 10 '18 at 16:21
  • It says warning ! - Unable to detect file system! Possible reasons are: - The file system is damaged - The file system is unknown to GParted - There is no file system available (unformatted) - The device entry /dev/sda2 is missing – jayendra.rakesh Jul 10 '18 at 16:24
0

When using windows 10 on sda3 and you install and boot ubuntu 18.04

sudo blkid
 (read uuid from /dev/sda3, used below as uuid_read_above)

sudo nano /etc/default/grub
 (add line to the end of the file:)
    GRUB_PRELOAD_MODULES="part_msdos"
sudo update-grub

sudo nano /etc/grub.d/40_custom
 (add these lines to the end of the file:)
    menuentry "Windows 10" {
     insmod ntfs
     set root='(hd0,3)'
     search --no-floppy --fs-uuid --set uuid_read_above
     ntldr /bootmgr
     chainloader +1     
    }
sudo update-grub

sudo grub-install /dev/sda
sudo update-grub

exit and boot from hdd, should see menu with "Windows 10"

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.