4

Environment:

Hardware: A laptop and a standalone monitor connected;

OS: Ubuntu 18.04

I'm very fond of the function to tile windows by side (https://help.ubuntu.com/stable/ubuntu-help/shell-windows-tiled.html.en), but there are something wrong with it on my computer.

Object: The "Files" window. I tried a lot of applications/windows, the tiling shortcuts work fine on all of them but only the "Files" window.

I open the "Files" window, press the Super + Left keys, nothing happened, and neither does Super + Right but I can maximize and restore the window by pressing Super + Up/Down and I can also switch the windows between my two monitors by pressing Super + Shift + Left/Right.

For other applications/windows, the Super + Left/Right/Up/Down all work fine.

BTW, the related settings in Settings - Devices - Keyboard are all correct.

I tried to turn on/off or change some related settings, nothing worked.

At the end I found one way to make the shortcut keys come into effect by dragging the window by the mouse, move it to the left or right side of the standalone monitor until the semi-transparent tiling indication appears, then I can tile the "Files" window to the left/right side of both the laptop monitor or the standalone monitor by Super shortcut keys.

After I close the "Files" window and reopen it, the problem comes again. Drag to tile, the problem is "fixed" again.

[UPDATE]

I just find another way to "fix" this problem by setting the standalone monitor as the primary display. In this case, I can directly tile the "Files" window by pressing Super+Left/Right normally. But I don't prefer this awkward display settings.

  • No buddy else comes into similar case? I don't know if this is a general bug or else? – Aaron Jul 11 '18 at 1:33
  • Now I set the standalone monitor as the primary display as a workaround, but I still wish to have this problem fixed and I strongly want to know the cause behind. Anyone have any related guess which may work can also point out for me to test. – Aaron Jul 12 '18 at 1:16
0

I've found a rather strange work-around. Click on the 'Files' application and switch off the 'Sidebar' setting. The windows then work correctly.

  • thanks for your answer, i'll try when back home. feedback would be a bit late. – Aaron Nov 4 '18 at 0:41
  • It works, but the sidebar is 100% necessary. Nautilus sucks. – Santropedro Jun 6 at 3:02
  • Santropedro - I wouldn't say Nautilus sucks. – Stevin Jed Jun 7 at 22:36
  • My work-around was 1/2 aimed at users & 1/2 aimed at those trying to make it better. For users, switching sidebar off, re-arranging windows then switching sidebar on again works. For developers why this happens has to be a big clue as to what's wrong. – Stevin Jed Jun 7 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.