6

Laptop in title has Ubuntu 18.04 installed and after installing the latest update yesterday (9.7.2018) fan(s) were running continuously. I have proprietary NVIDIA drivers installed and until yesterday everything worked fine.

After inspecting temperatures, I compared them to a similar setup (samo brand and model and Ubuntu 18.04) and mine were relatively high and the same goes for fan speeds.

> sensors
dell_smm-virtual-0
Adapter: Virtual device
Processor Fan: 4104 RPM
Video Fan:     4100 RPM
CPU:            +62.0°C  
Ambient:        +60.0°C  
Ambient:        +56.0°C  
Other:          +39.0°C  

acpitz-virtual-0
Adapter: Virtual device
temp1:        +25.0°C  (crit = +107.0°C)

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +57.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +58.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +57.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +57.0°C  (high = +100.0°C, crit = +100.0°C)

This is the other laptop which works as expected:

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +52.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +52.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +52.0°C  (high = +100.0°C, crit = +100.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1:        +25.0°C  (crit = +107.0°C)

dell_smm-virtual-0
Adapter: Virtual device
Processor Fan: 2514 RPM
Video Fan:     2504 RPM
CPU:            +56.0°C  
Ambient:        +50.0°C  
Ambient:        +48.0°C  
Other:          +36.0°C  

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +52.0°C  

3 Answers 3

7

My guess is that something has been done with the graphics drivers. Until this is fixed, an intermediate solution is to switch to onboard graphics (see here). In short, run nvidia-settings and select PRIME Profiles and use Intel (Power Saving Mode).

This is the image from the link: enter image description here

You should see the change in Details enter image description here

7
  • fixed the same problem for me!
    – Guangliang
    Commented Jan 19, 2019 at 1:49
  • 2
    The issue has not been resolved in 19.04. Commented Jun 24, 2019 at 15:24
  • This continues to be a real annoyance, even with the laptop on my desk. If you look in the "PowerMizer" section of the nvidia-settings app, the performance level seems to be pinned at 2-3 (ie - use a lot of power and run hot), when for "normal" use I'd expect 0-1 to be good enough (how much GPU power do you need to throw a few flat windows around?).
    – Adrian
    Commented Oct 21, 2019 at 9:23
  • 1
    So ; for an alternate solution I tried this answer. Upside - it definitely forces the performance mode to 1 or 0, and there's a noticeable reduction in fan usage. Downside : there's a noticeable reduction in performance too. Even scrolling a webpage becomes really clunky and laggy. Now, I'm using Unity, so this might be one reason. Main reason I'm trying the nvidia instead of the Intel is that eventually (after suspending a few times) the texture memory fragments and it grinds to a halt and needs a reboot. askubuntu.com/questions/1061919/…
    – Adrian
    Commented Oct 21, 2019 at 9:37
  • 1
    .. and back to the Intel GPU, and everything is as smooth as silk again. Something very wrong when integrated graphics outperforms a dedicated workstation-level card on basic desktop compositing.
    – Adrian
    Commented Oct 21, 2019 at 9:47
3

Install i8kutils:

sudo apt install i8kutils

Follow the guide How to solve Dell laptops fan issues in Ubuntu.

2
  • 1
    Thanks for your input. I have thought of this solution, but I opted for switching to onboard graphics until this issue is solved on the level which was broken (kernel? graphics drivers?). Commented Jul 10, 2018 at 11:20
  • This solution is useful if your device is overheating for reasons other than NVIDIA drivers. I have uninstalled all NVIDIA drivers but was having issues with my fans running. This solution fixed it for me Commented May 1, 2020 at 1:26
1

I have the same laptop and had the same issue in Ubuntu 18.04 and then Ubuntu 20.04. Basically, it's caused by the Nvidia drivers.

If you are only doing non graphical intensive tasks on your laptop:

  • run NVIDIA X Server Settings then under PRIME profiles switch to intel (power saving mode).

** /!\ NEXT SOLUTION IS AT YOUR OWN RISK /!\ **

Else, install greenwithenvy (https://gitlab.com/leinardi/gwe). To be able to access the full capabilities of that software, you will have to enable the Cool Bits Option to a certain value (https://wiki.archlinux.org/index.php/NVIDIA/Tips_and_tricks#Enabling_overclocking). To do that, I did :

sudo gedit /usr/share/X11/xorg.conf.d/10-nvidia.conf

then I added the following line

Option "Coolbits" "29"

after the Driver Nvidia line. (What that guy did --> https://ubuntuforums.org/showthread.php?t=2435095)

Once you modified that, restart your computer and pray for your GUI to not be broken... If that were the case, follow that guide: https://itsfoss.com/fix-ubuntu-freezing/ and rollback what you just did. Find another way, can't help you there. Sorry.

If that worked, you should be able to access the fan options and other overclocking stuff greenwithenvy allows you to do. You can tweak the fan behaviour, try the custom one they propose, it's good. Regarding the overclock profile, create a new one and assign the lowest negative values allowed for your GPU Offset and Mem Offset. I use -200 and -1000. Yes, you will loose a bit in term of performance but on the other hand, your laptop wont overheat for nothing, or worse, turn itself off...

Note that now you can also use Nvidia X Server Settings to underclock your GPU using Powermizer.

Hope that helps.

3
  • 2
    Thanks for your answer. In the mean time, I've learned that one should not buy a 2500 EUR laptop with a fancy graphics card to run linux. Commented May 11, 2020 at 8:18
  • @RomanLuštrik Or just buy an AMD one it works a lot better with linux. In my defense I didnt choose as it is my work laptop...
    – Ludo
    Commented May 11, 2020 at 13:15
  • Any suggestions on which laptop that would be right now? Commented May 11, 2020 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .