10

I know this question has been asked before, but I want to see if anyone has a better solution than the one I have. I am using a Thinkpad 440p, previously with Ubuntu 18.04, currently with Ubuntu Mate 18.04. I've had this issue with elementary os and mint. When my computer suspends and I start it up again, the scrolling no longer works. The solution I found was to modprobe -r psmouse and modprobe psmouse. This fixes it instantly and I wrote a script to do it but I have to run the script everytime I resume from suspend. I was just wondering if anyone has a permanent solution.

3 Answers 3

5

After some digging I used a combination of your solution and this answer.

On Ubuntu 18.04, I placed the following script in /lib/systemd/system-sleep/psmouse-refresh. This reloads the module after suspend.

#!/bin/bash

# $1 is the state (pre or post)-sleep
if [[ $1 == post ]]; then
    modprobe -r psmouse
    modprobe psmouse
fi

make it executable

chmod +x /lib/systemd/system-sleep/psmouse-refresh
4

The above worked for me using...

modprobe -r usbhid
modprobe usbhid
1
  • This should be the accepted answer, just with caution that just removing usbhid would disable all externally (usb) connected keyboards. That's why using && is important Commented Apr 18, 2021 at 9:52
2

I tried a few workarounds. Following worked for me.

Updated the /etc/default/grub parameters as:

GRUB_CMDLINE_LINUX_DEFAULT="psmouse.synaptics_intertouch=0 quiet splash"
GRUB_CMDLINE_LINUX="i8042.reset i8042.nomux i8042.nopnp i8042.noloop"

After this run:

sudo update-grub
sudo reboot

For testing the workaround: Put your system to sleep using following command:

sudo systemctl suspend

Turn on the system and verify the mouse scroll wheel if it works.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .