I have an RCA W101v2 Tablet running Windows 10, but the Spring 2018 update took away a lot of my functionality as they decided not to support my (Intel(R) Atom(TM) CPU Z3735F @ 1.33GHz) chipset any longer. It was suggested to me that Linux LUbuntu might be a better alternative and I've been curious about Linux for awhile now.

I followed the directions getting the LUbuntu 18.04 ISO on a USB (first with Rufus then with Universal USB installer both said they were successful and I could access many files, not just an ISO on it, but it made no difference. For Clarification: I started with a brand new USB stick, let Rufus format it and extract the ISO files onto it. There are no other files on it.) and tried to get my BIOS/UEFI to the right settings to boot from the USB without any luck - it just ignores it and boots to Windows. The info for my BIOS is as follows, if it helps:

American Megatrends Core Version - 5.008 Compliancy - UEFI 2.3;PI 1.2 Project Version - BSW10EHV-W101V2-RCA-V32

I've gone to the American Megatrends and RCA support sites, but they were less than helpful. Is there any way to install it without going thru the usb? Obviously, I don't have a CD drive.

I am a newbie to Linux, but I can follow directions and I've been using Windows comfortably forever. If I've left relevant info out, just let me know and I'll get it to you ASAP.

The "How do I install Ubuntu" doesn't answer my question because it assumes you will be able to install from the USB.

Someone suggested the Linuxium isorespin to help, which does have drivers for Atom computers, but the basic problem remains: I can't boot from the USB drive and the Isorespin only works if you can access Linux CLI, there are no instructions for a Windows solution. My problem remains.

Thanks in advance for your time.

  • "first with Rufus then with Universal USB installer - no difference" doesn't tell us if the USB creation succeeded or failed, nor how you tested to determine success or failure. – user535733 Jul 9 '18 at 21:04
  • As far as I could tell, both Rufus and the other worked - I was able to access them thru Windows. Is there another test? both programs said it was successful. – Angelmaat Jul 9 '18 at 21:12
  • What does "I was able to access them thru Windows" mean? – user535733 Jul 9 '18 at 21:30
  • see above edit user 535733. – Angelmaat Jul 9 '18 at 21:38
  • 1
    If you could "could access many files, not just an ISO", then the USB installer seems not made properly, and was not bootable. You don't place the ISO onto the USB stick - you overwrite everything on the USB stick with the ISO image. You need Rufus to do that properly - it's not a File Manager operation, it's a full disk re-imaging. – user535733 Jul 10 '18 at 3:06

Browse other questions tagged or ask your own question.