2

my WiFi adapter Qualcomm Atheros QCA9565/AR9565 Wireless Network Adapter.doesn't work or even appear in the system settings.I'm using ubuntu 18.04 with a dual boot with windows 10.the WiFi adapter works in windows. output of lspci -knn | grep Net -A3:

03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
Subsystem: Lite-On Communications Inc QCA9565 / AR9565 Wireless Network Adapter [11ad:0803]
Kernel modules: ath9k

lspci -knn | grep Net -A2

03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
Subsystem: Lite-On Communications Inc QCA9565 / AR9565 Wireless Network Adapter [11ad:0803]
Kernel modules: ath9k

sudo rfkill list

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

sudo lshw -C network

*-network  

   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 15
   serial: 1c:39:47:53:6c:4b
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:-2147483648 ioport:3000(size=256) memory:c1104000-c1104fff memory:c1100000-c1103fff
 *-network UNCLAIMED
   description: Network controller
   product: QCA9565 / AR9565 Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list
   configuration: latency=0
   resources: memory:c1000000-c107ffff memory:c1080000-c108ffff
 *-network
   description: Ethernet interface
   physical id: 1
   logical name: enp0s20u1
   serial: 76:f5:dc:14:1d:16
   capabilities: ethernet physical
   configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.239 link=yes multicast=yes

dmesg | grep ath9k

[   21.252360] ath9k 0000:03:00.0: PCI INT A: not connected
[   21.252404] ath9k 0000:03:00.0: request_irq failed
[   21.252423] ath9k: probe of 0000:03:00.0 failed with error -107
8
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Jul 9 '18 at 16:46
  • It is not the full output. – Pilot6 Jul 9 '18 at 19:07
  • it is the acer e5 573 laptop – gustavo oliveira Jul 9 '18 at 19:23
  • The -A3 should show the module in use or some other device. – Pilot6 Jul 9 '18 at 19:25
  • i'm sorry pilot6 i don't understand what you mean – gustavo oliveira Jul 9 '18 at 19:26
0

Pay you attention command lspci -knn | grep Net -A2 output contains no line Kernel driver in use. Just do

sudo modprobe ath9k

Next check the wireless module for soft and hard block

sudo rfkill list

As your laptop is Acer, try

echo blacklist acer-wmi | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf

Reboot the laptop and try lspci -knn | grep Net -A2 and sudo rfkill list again.

If nothing helps try No Wifi on Acer Aspire E5 573 on any Linux Platform.

And finally try solution from post #22 from here.

ADDENDUM

Do

cd
sudo apt update
sudo apt install git
git clone https://github.com/kvalo/ath10k-firmware.git
sudo rm -rf /lib/firmware/ath10k
sudo cp -r ath10k-firmware/ /lib/firmware/ath10k/
sudo mv /lib/firmware/ath10k/QCA6174/hw2.1/firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1 /lib/firmware/ath10k/QCA6174/hw2.1/firmware-5.bin
sudo chmod +x /lib/firmware/ath10k/QCA6174/hw2.1/*
sudo chmod +x /lib/firmware/ath10k/QCA6174/hw2.1/firmware-5.bin

Reboot laptop.

ADDENDUM #2

Try

sudo apt install --reinstall linux-firmware

Reboot laptop.

1
0

I had the same problem with ubuntu 17 and i solved following the below steps.

First of all, I tried to download the network kernel from site --> https://ubuntu.pkgs.org/17.10/ubuntu-restricted-amd64/bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu3_amd64.deb.html

If your architecture is x64,

sudo dpkg -i bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu3_amd64.deb
sudo apt install -f

Then, I saw the configuration of network service

 cat /etc/NetworkManager/NetworkManager.conf 

By default, there are

 [main]`
 plugins=ifupdown,keyfile

 [ifupdown]
 managed=false

 [device]
 wifi.scan-rand-mac-address=no

if it is different of yours, change it.

Then, you need to restart the kernel configuration.

  sudo service network-manager restart

Reboot the computer.

On bios, change the boot secure:

boot secure: disabled   ->    boot secure: enabled

And ok.

Works in ubuntu 17, Positivo Stilo XCi7660.

bye

0

As I had problems with the WiFi network and Atheros driver on ubuntu I asked for advice also on askubunt. The laptop did not show a WiFi network. On the internet, tips like installing drivers for a WiFi adapter didn’t help. I solved the problem by simply resetting the router. So it was not a problem in the laptop or ubuntu but the router. Try resetting the router or resetting the router to factory settings. Also if you've installed linux on your laptop multiple times you've probably made a mess with secure boot and maybe that's why you can't have WiFi on ubuntu if secure boot is enabled. Therefore, before a clean new installation of ubuntu, reset the BIOS / UEFI secure boot to factory settings and reinstall ubuntu. At least that's how it is on an acer laptop.

Admin sorry I followed up on an old topic but it might help someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.