1

This question already has an answer here:

ORIGINAL QUESTION:

When I try to mount an ISO file using:

  1. Right click the file and select [Open With] > [Archive Mounter]
  2. Right click the file and select [Open With] > [Disk Image Mounter]
  3. [gnome-disk-utility] > [Disks] > [Attach Disk Image]
  4. sudo mount -o loop '/media/oshirowanen/250GB.iso' /media/iso

I get the following error message for attempts 1, 2, 3, and 4:

Unable to access “New Volume”
Error mounting /dev/loop10p1 at /media/oshirowanen/New Volume: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/loop10p1" "/media/oshirowanen/New Volume"' exited with non-zero exit status 21: ntfs-3g-mount: mount failed: Permission denied
Failed to sync device /dev/loop10p1: Input/output error
Failed to close volume /dev/loop10p1: Input/output error

Anyone know how to resolve this?


UPDATE 1:

  1. sudo mount -o ro,loop /media/oshirowanen/250GB.iso /media/iso

The following error is given for attempt 5:

mount: wrong fs type, bad option, bad superblock on /dev/loop12,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

Possible useful info

The iso was created from an ntfs drive using the command

sudo dd if=/dev/sde | pv | sudo dd if=/media/oshirowanen/250GB.iso

marked as duplicate by Amith KK, sudodus, karel, Eric Carvalho, David Foerster Jul 10 '18 at 9:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Are you an admin on the system? If so, do you get permission errors for any other typical admin activity? – user535733 Jul 9 '18 at 15:56
  • @user535733, I don't use the computer as an admin for normal stuff, I usually use sudo if I want to do something with elevated privileges. I've just tried sudo aptitude update, and it worked fine without any errors. – oshirowanen Jul 9 '18 at 15:58
  • Can you please try sudo mount -o ro,loop /media/oshirowanen/250GB.iso /media/iso – Amith KK Jul 9 '18 at 16:07
  • @AmithKK, I've added the details of your suggestion to the question above as attempt 5. – oshirowanen Jul 9 '18 at 16:11
  • 2
    I have a feeling because you dd the WHOLE drive, and not just a partition, the MBR (or GPT) is there as well. As such, you might find the right way of mounting it here: link – G Trawo Jul 9 '18 at 17:02
1

First of all create directory:

sudo mkdir /media/iso

Check if your image has a boot sector:

sudo file /media/oshirowanen/250GB.iso

If your drive image has a boot sector, issue the command in terminal:

sudo fdisk /media/oshirowanen/250GB.iso

Find in the table in Start column number, let it be 64 for example. Multiply this number by 512 (sector size), i.e. 64x512=32768. And finally mount your image with offset option:

sudo mount -o loop,offset=32768 /media/oshirowanen/250GB.iso /media/iso

Not the answer you're looking for? Browse other questions tagged or ask your own question.