Xubuntu 18.04, 4.15.0-24-generic, ThinkPad T430. Uses Intel HD iGPU graphics (nvidia dGPU disabled in BIOS).

Recently started having this issue with a slow boot, where the boot process hangs on a black screen for an indefinite period of time before finally displaying the normal login splash screen.

Process looks like:

  • OEM Bios select screen
  • blank, black screen (< 1 sec)
  • Blue Xubuntu title splash (< 2 sec)
  • Some grub printout (< 1 sec)
  • A black screen that has a blinking white cursor block (< 1 sec)
  • A blank, black screen with nothing on it (approx. 10 sec)
  • Finally, login splash screen

No idea why it started doing this. Was working fine before. The only thing I've noticed, which may be a red herring or irrelevant, is that there have been a bunch of updates to the mesa package lately when I apt update and upgrade.

Most other posts I've seen related to a hanging black screen on boot are either ancient (12.04) or unrelated (stuck on grub, or the flashing-cursor screen instead of blank). Though it seems like most of those posts are related to editing the grub file (/etc/default/grub line GRUB_CMDLINE_LINUX_DEFAULT).

Any ideas?

For reference, my grub file reads:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.runpm=0"

and the relevant output of lscpi -k

lspci -k
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
Subsystem: Lenovo 3rd Gen Core processor Graphics Controller
Kernel driver in use: i915
Kernel modules: i915

Things I've tried:

  • change GRUB_CMDLINE_LINUX_DEFAULT to "quiet splash instead of "quiet splash nouveau.runpm=0"
  • GRUB_TIMEOUT=0 instead of 10
  • updating mesa, xserver-xorg-video-intel packages, both already installed and current
  • updating kernel (was already at latest, 4.15.0-24-generic)


Unfortunately was not able to figure out the source of the issue. I tried nearly every permutation of grub settings, but that did not end up changing the hanging boot issue. My guess it is probably related to the 4.15.0-24-generic. Decided to reinstall Xubuntu 16.04 for this issue and a few more I've had with 18.04.

If anyone else is experiencing this hanging boot issue and solved the issue, please provide your solution for others (and possibly me if I decide to roll the dice again when Xubuntu 18.04.1 drops).

  • The 4.15.0-24 kernel is known to have some problems. To see if that may be a part of your problem, try moving the mouse during slow boot up, and see if it boots faster/normally. Report back to @heynnema. – heynnema Jul 9 '18 at 17:12
  • Remove the quiet to see what's happening during the 10 seconds. – WinEunuuchs2Unix Jul 9 '18 at 18:00
  • @Wiking I took a look at the journalctl, but I did not see anything obvious, but then again, not sure if I would know if I did. Probably should have dumped here for the experts. Thanks anyway. @heynnema So the mouse thing did not change anything. But the screen generally stays black for a minimum of 8-10 sec, and it seems to persist past then if I do not mash the keyboard. @WinEunuuchs2Unix removing quiet did not change anything to the hanging black screen, which comes after the grub splash (which is <1.5 sec). – Alnitak Jul 16 '18 at 0:55

From the comments...

The 4.15.0-24 kernel is known to have some problems. To see if that may be a part of your problem, try moving the mouse during slow boot up, and see if it boots faster/normally.

If that improves the boot time, boot to a prior kernel like 4.15.0-23, and/or wait for a newer kernel to arrive.

Update #1:

Edit /etc/gdm3/custom.conf and change:




and see if that helps.

| improve this answer | |
  • thanks for your suggestion. I bungled something during the downgrade and messed a few things up, though I do think the problem is probably the kernel. Ended up just reinstalling 16.04, for this boot lag, as well as a few other annoyances. Will reconsider 18.04 when .1 drops – Alnitak Jul 16 '18 at 0:47
  • @Alnitak Too bad that you already downgraded. There's a setting in /etc/gdm3/custom.conf that I would have wanted you to try. It has to do with gdm3 and wayland. – heynnema Jul 16 '18 at 13:16
  • @Alnitak I have the exact same problem: A blank, black screen with nothing on it (approx. 20 sec) @heynnema editing /etc/gdm3/custom.conf didn't help my kernel is Linux hpx360-13 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux I've resized my ex4 and swap from 37GB , 8G to 44GB 1GB respectively. I have 8GB RAM but I saw that the system doesn't use it and hibernation takes less then 0.5GB space. But I think it lagged my boot though I've changed the swap partition UUID in etc/fstab according to blkid info – Roey Jul 31 '18 at 13:47
  • @heynnema roey@hpx360-13:~$ systemd-analyze Startup finished in 2.264s (firmware) + 2.738s (loader) + 33.699s (kernel) + 11.062s (userspace) = 49.766s graphical.target reached after 10.956s in userspace is that in the normal range ? – Roey Jul 31 '18 at 15:24

I had the exact same problem and upgrading to 4.15.0-29 fixed it. Previously I had downgraded to 4.15.0-23 which also worked, so it seems like this was a problem with 4.15.0-24.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.