0

I recently installed Ubuntu 16.04 on my 5 year old Lenovo and immediately my touchpad didn't work. I looked around and found a solution (can't find the link) which told me to do this:

sudo apt-get install aptitude
sudo aptitude update
sudo aptitude install xserver-xorg-input-synaptics

aptitude told me that a bunch of other xserver-xorg items would be removed to deal with the dependencies (apologies but I did not write down which ones though there were about 10 of them all related to xserver-xorg), and after installing and rebooting, my touchpad, keyboard and touchscreen all worked. I rebooted again the other day and now only my touchpad works.

I've looked online for other solutions, but none of the ones I've looked at have been helpful. I was thinking it might just be a case of reinstalling all the xserver-xorg packages that I uninstalled, but I'm not sure how to go about this since there are so many of them. Also any deeper insight into why my touchpad wouldn't work would be appreciated - it used to do the same thing to me on Windows until I installed the Synaptics drivers.

EDIT: The mouse and keyboard which I plugged in to my laptop were also not recognised.

EDIT #2: I ran sudo apt-get install xserver-xorg-input-all and now I'm right back where I started - touchpad not working, everything else fine.

  • So this was on a fresh install? I suggest booting from a Live USB, which should reproduce the original situation with the touchpad, to see (and save for reference) the packages involved. – Ratler Jul 10 '18 at 0:09
  • Also, test 18.04. You might be lucky and everything just works out of the box! – Ratler Jul 10 '18 at 0:11
  • @Ratler So actually 18.04 had the same problem as well as a bunch of others so I installed 16.04 instead. Booting from USB could be a good idea though – Sebastian Jul 10 '18 at 11:47
  • Try what I suggested here to fix your scrolling. – Eugene Frakt Dec 14 '18 at 9:39
0

I followed this answer which solved the issue, though I can't scroll as of yet. Weird that this bug is still an issue after 5 years.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.