0

I have found relevant questions, but all of them are for very old versions of ubuntu, so I open a new one.

The problem: I want to use two different monitors on two different nvidia GPUs, as a single layout. My setup: Ununtu 18.04, nvidia 390.48 drivers, primary GPU nVidia 1070 Ti 8GB, primary display Dell 27", secondary GPU nVidia 1060 6GB, secondary display Eizo 19".

The primary display on primary GPU works OK. The secondary display (connected on the secondary GPU via DVI cable) is not detected from Ubuntu's display manager, only from nVidia's proprietary X Server Settings. The mouse cursor moves to this monitor, but it appears as a big white X and the desktop does not extend on this monitor (no wallpaper and no windows appear when I drag them to it).

My Xorg.conf is as follows:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig `
# nvidia-xconfig:  version 384.111  (buildmeister@swio-display-x86-rhel47-01)  Wed Dec 20 00:05:28 PST 2017

Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen1"
Screen      1  "Screen0" RightOf "Screen1"
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier     "Keyboard0"
Driver         "kbd"
EndSection

Section "Monitor"
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Unknown"
HorizSync       28.0 - 33.0
VertRefresh     43.0 - 72.0
Option         "DPMS"
EndSection

Section "Monitor"
Identifier     "Monitor1"
VendorName     "Unknown"
ModelName      "Unknown"
HorizSync       28.0 - 33.0
VertRefresh     43.0 - 72.0
Option         "DPMS"
EndSection

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GTX 1060 6GB"
BusID          "PCI:6:0:0"
EndSection

Section "Device"
Identifier     "Device1"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GTX 1070 Ti"
BusID          "PCI:7:0:0"
EndSection

Section "Screen"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "AllowEmptyInitialConfiguration" "True"
Option         "Coolbits" "28"
SubSection     "Display"
    Depth       24
EndSubSection
EndSection

Section "Screen"
Identifier     "Screen1"
Device         "Device1"
Monitor        "Monitor1"
DefaultDepth    24
Option         "AllowEmptyInitialConfiguration" "True"
Option         "Coolbits" "28"
SubSection     "Display"
    Depth       24
EndSubSection
EndSection`

Output of sudo hwinfo --gfxcard --monitor:

09: PCI 700.0: 0300 VGA compatible controller (VGA)             
[Created at pci.378]
Unique ID: aK5u.oOaDz0eX0w4
Parent ID: w+J7.0TU4LKoL980
SysFS ID: /devices/pci0000:00/0000:00:03.1/0000:07:00.0
SysFS BusID: 0000:07:00.0
Hardware Class: graphics card
Model: "nVidia GP104"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x1b82 "GP104"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x861e 
Revision: 0xa1
Driver: "nvidia"
Driver Modules: "nvidia"
Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
Memory Range: 0xd0000000-0xd1ffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xffff (rw)
Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
IRQ: 64 (1140659 events)
Module Alias: "pci:v000010DEd00001B82sv00001043sd0000861Ebc03sc00i00"
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: "modprobe nvidiafb"
Driver Info #1:
Driver Status: nouveau is not active
Driver Activation Cmd: "modprobe nouveau"
Driver Info #2:
Driver Status: nvidia_drm is active
Driver Activation Cmd: "modprobe nvidia_drm"
Driver Info #3:
Driver Status: nvidia is active
Driver Activation Cmd: "modprobe nvidia"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #30 (PCI bridge)

16: PCI 600.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: vTuk.hjP6Elgh+F6
Parent ID: UVH2.sArAqRDibeE
SysFS ID: 
/devices/pci0000:00/0000:00:01.3/0000:01:00.2/0000:02:04.0/0000:06:00.0
SysFS BusID: 0000:06:00.0
Hardware Class: graphics card
Model: "nVidia GP106 [GeForce GTX 1060 6GB]"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x1c03 "GP106 [GeForce GTX 1060 6GB]"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
SubDevice: pci 0x8c94 
Revision: 0xa1
Driver: "nvidia"
Driver Modules: "nvidia"
Memory Range: 0xf4000000-0xf4ffffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
I/O Ports: 0xd000-0xefff (rw)
Memory Range: 0xf5000000-0xf507ffff (ro,non-prefetchable,disabled)
IRQ: 68 (395337 events)
Module Alias: "pci:v000010DEd00001C03sv00001462sd00008C94bc03sc00i00"
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: "modprobe nvidiafb"
Driver Info #1:
Driver Status: nouveau is not active
Driver Activation Cmd: "modprobe nouveau"
Driver Info #2:
Driver Status: nvidia_drm is active
Driver Activation Cmd: "modprobe nvidia_drm"
Driver Info #3:
Driver Status: nvidia is active
Driver Activation Cmd: "modprobe nvidia"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #28 (PCI bridge)

When I plug both monitors on the primary GPU (1070Ti), they work just fine. However, I need both GPUs, because I want to setup a dual monitor for a flight simulator - so 3D graphics need the performance of different GPU on each monitor.

Any ideas please?

  • Hi digibill and welcome to askubuntu! Please add the output of sudo hwinfo --gfxcard --monitor in your post. – abu_bua Jul 9 '18 at 9:00
  • Done it, I have included it in the original post. – digibill Jul 9 '18 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.