5

I recently upgraded to Kubuntu 18.04 (therefor to kernel 4.15.0-23). I can't suspend my computer anymore. However, booting on a previous kernel version still lets me suspend my computer.

This is what exactly happens when I hit on 'Suspend': System goes black, suspends (led blinking), awake by itself 1-2 seconds later.

Would you think there's an issue in the kernel? Is there any config/conflict issue ?

Thanks for your help!

Cheers,

Here are the logs:

journalctl -b | grep sleep

juil. 07 16:15:25 user-ubuntu NetworkManager[1016]: <info>  [1530972925.7995] manager: sleep: sleep requested (sleeping: no  enabled: yes)
juil. 07 16:15:25 user-ubuntu NetworkManager[1016]: <info>  [1530972925.7996] device (wlp2s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
juil. 07 16:15:26 user-ubuntu systemd-sleep[6022]: Suspending system...
juil. 07 16:15:31 user-ubuntu kernel: ACPI: Preparing to enter system sleep state S3
juil. 07 16:15:31 user-ubuntu kernel:  cache: parent cpu1 should not be sleeping
juil. 07 16:15:31 user-ubuntu kernel:  cache: parent cpu2 should not be sleeping
juil. 07 16:15:31 user-ubuntu kernel:  cache: parent cpu3 should not be sleeping
juil. 07 16:15:31 user-ubuntu kernel: ACPI: Waking up from system sleep state S3
juil. 07 16:15:31 user-ubuntu systemd-sleep[6022]: System resumed.
juil. 07 16:15:31 user-ubuntu systemd[1]: sleep.target: Unit not needed anymore. Stopping.
juil. 07 16:15:31 user-ubuntu systemd-logind[995]: Operation 'sleep' finished.
juil. 07 16:15:31 user-ubuntu NetworkManager[1016]: <info>  [1530972931.6845] manager: sleep: wake requested (sleeping: yes  enabled: yes)

journalctl -b | grep suspend

juil. 07 16:15:26 user-ubuntu kernel: PM: suspend entry (deep)
juil. 07 16:15:31 user-ubuntu kernel: Suspending console(s) (use no_console_suspend to debug)
juil. 07 16:15:31 user-ubuntu kernel: PM: suspend exit
juil. 07 16:15:31 user-ubuntu systemd[1]: suspend.target: Unit not needed anymore. Stopping.
6

Got it! My USB wifi dongle seemed to wake my system up.

Step 1: check what is allowed to wake up your system:

Open a terminal:

sudo nano /proc/acpi/wakeup

Step 2: understand the results:

Screenshot of /proc/acpi/wakeup content - step 1

The list shows what device can awake your computer. Here: EHC1 - EHC2 - XHC

Step 3: Block the device that wake up your computer:

Disable EHC1 in your terminal with:

echo EHC1 | sudo tee /proc/acpi/wakeup

Suspend your computer. If it still awakes, try

echo EHC2 | sudo tee /proc/acpi/wakeup

Note: EHC2 instead of EHC1. You can also try with XHC)

Note: above command is a kind of toggle. If you use it 2 times in a row, it will turn off EHC1, then turn it back on

Step 4: Confirm it worked

Here, it was EHC2 that woke up my computer (my USB wifi dongle). Now, it's disabled, it cannot awake my computer, and it stays suspended.

Screenshot of /proc/acpi/wakeup content - step 2

0

I had exactly the same symptom, but had nothing plugged in (USB). The notebook would wake up again immediately after closing the lid.

In my case I fixed it once by going to System Settings > Power Management and experimenting with every possible option. It worked for me to disable "Suspend session" on the "On battery" tab. This option sets up the automatic suspension of the computer after certain time, but disabling it somehow fixed the inability to suspend the computer.

I then started again experimenting with the options and the problem came back, this time it didn't work to disable automatic suspension after some time.

I then found an article (https://bibhasdn.com/blog/fixing-immediate-resume-of-system-after-suspend-on-linux-mint-ubuntu/) explaining how to do something similar to the answer provided by the OP here and, after disabling XHC1 (USB 3.0 chip), the only option able to resume the computer other than the open lid action, the bug was fixed.

The steps were:

  1. Type in the terminal sudo cat /proc/acpi/wakeup
  2. Identify the options that can wake up the computer (enabled)
  3. Disable one by one, starting with the low priority ones (careful, read the article to know which ones to leave alone)

I am running Kubuntu KDE Plasma (Ubuntu 18.04.2 LTS) on a 2017 Macbook Air.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.