0

I followed the instructions to install the autocomplete tool TextSuggest but now I'm stuck at this part:

Run the command textsuggest-server in the background, and set it to run on startup.

Set the command textsuggest to a keyboard shortcut. Type a word, select it, press the shortcut and TextSuggest will give you autocomplete.

After running the command in the terminal this error comes up:

doit@tox:~$ textsuggest-server
textsuggest-server: command not found

Same error if I run it in the CD of textsuggest. Also I got this error after the installation:

/usr/include/dbus-c++-1/dbus-c++/dispatcher.h:249:13: note: conversion of argument 3 would be ill-formed
Makefile:416: recipe for target 'textsuggest-ui.o' failed
make: *** [textsuggest-ui.o] Error 1

How to get it to work? I'm using gcc (Ubuntu 7.2.0-8ubuntu3.2) 7.2.0.

  • which version of Ubuntu are you running? – Sebastian Stark Jul 17 '18 at 10:28
  • I'm running Ubuntu 17.10 – Tom Jul 17 '18 at 10:51
  • 2
    This is a bug in the source code of TextSuggest (that likely only becomes apparent due to different default settings in newer GCC releases). Please file a bug report with the developers/maintainers of TextSuggest. I'd vote to close but that doesn't work on questions with open bounties. – David Foerster Jul 18 '18 at 14:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.