1

I just manually installed Firefox Developer Edition by extracting the tarball to a folder in my /home directory, creating a .desktop launcher and putting that in /home/.local/share/applications. Now I can't set FDE as the default browser. No matter how many times I launch it and hit "yes" on the "make default browser" prompt, that prompt comes up the next time I launch it, and it's still not default.

When I go into Settings > Details > Default Applications, the drop-down menu for "Web Browser" only contains the old Firefox and something called "Browser". How can I make Ubuntu see FDE?

  • Note: I found this question, but it's written in a very confused way and the answers don't really address the problem, in particular FDE not showing up in the settings menu isn't mentioned. Maybe that question should be closed as a duplicate of this one. – Jack M Jul 8 '18 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.