We cannot seem to install Ubuntu Server with USB as it reboots when I hit 'enter' for 'Install Ubuntu Server' option.

My friend wants to try setting up a server so; we downloaded Ubuntu Server 10.04.4

we created a boot CD and installed ubuntu server no problem at all.

But then the problem arose the hardrive we wanted to use is a 1tb sata drive and the computer orginally has 40gb IDE. So I bought a Sata to IDE and IDE to Sata converter from:


Unfortunately this converter means I cannot plug in the IDE cable meaning I only have one IDE connection i.e CD drive has to be disconnected for the 1tb sata Hardrive to be connected.

So now the 1tb drive is connected, powered it on opened the bios to make sure the hdd appeared it did as ST3ASDAPFKG (somthing like that).

Fortunately the computer supports USB booting, so I read ubuntu server usb install instructions I tried: Startup Disk Creator & Unebootin

Startup Disk Creator made the usb bootable with the 'ubuntu-10.04.4-server-i386.iso' All looked fine stuck the usb drive in, booted the machine up and I am quickly presented with ubuntu language choice. I hit enter to select English then I am presented with:

  • Install Ubuntu Server,
  • Install Ubuntu Enterprise Cloud,
  • Check Disk for defects,
  • test memory,
  • Boot from first hard disk,
  • Rescue a broken system

I can move up and down the menu fine everything seems ok, I select 'Install Ubuntu Server', computer just hangs and screen either goes blank or locks. So I rebooted the computer loads the same menus fine, I select 'Install Ubuntu Server' hit 'enter' and the computer just restarts then brings me back to the same menu. hmmm

Then I tried choosing the rest of the options separately: Install Ubuntu Server, Install Ubuntu Enterprise Cloud, Check Disk for defects, test memory, Boot from first hard disk, Rescue a broken system

computer just restarts and back to the same ubuntu menu every-time. Grrrr

At this point I wish I actually new how to command line install or something but I don't have a clue how to do that. So I tried hitting 'f6' for 'other options' and I tried them all in various combinations and individually. No Luck:

(Expert mode, acpi=off, noapic, nolapic, edd=on, nodmraid, nomodeset, Free Software only)

At this point I am wondering if it is a bios setting causing problems, I tried turning every option in there on off that I don't understand. No Luck.

I then discovered by accident if you hit esc in the ubuntu install menu it says "you are leaving the graphical boot menu and starting the text mode interface" I hit 'Ok'. Next a prompt pops up saying 'boot:' One time it responded when I typed somthing with 'Cannot find kernal image (something like that but since then it just restarts when I hit enter in that prompt).

I had a browse on the net and found someone suggesting removing quiet from install command for 'Install Ubuntu Server'. Made no difference at all just reboots...

Orginal boot options noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu-server.seed initrd=/install/initrd.gz quiet --

Modified boot options noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu-server.seed initrd=/install/initrd.gz --

Still I cannot install Ubuntu Server by USB as it, reboots when I hit 'enter' for 'Install Ubuntu Server' option.

This is a real pain as we cannot take the 1tb Sata Hardrive and swap it for IDE to be able to use the cd drive. Why is is it so hard to install ubuntu server with usb? I have wasted a full day and half on this really frustrated any help would be amazing! I know the answers out there just seems a bit illusive at the moment!

Computer Spec-

Asus Motherboard, 1gb RAM 2X512MB, Powersupply 200watt, 2.8ghz Processor Intel, On-board 64mb graphics, 100mb Ethernet, 54mb Wireless,


At that point you're past the BIOS, so you shouldn't have any problems.

It sounds like what's happening is that the kernel and/or the initial ram disk may be corrupted (more likely the kernel). You should try re-making the USB stick, perhaps with a re-downloaded copy of the ISO (did you md5sum the ISO before using it to create the stick?). Or, you may have better luck using the most-recent version of Ubuntu Server - 11.10.

  • Hello, thanks for the fast response, I cannot check the hash Tag because they have not uploaded that version yet; ubuntu server 10.04.4 they only have ubuntu server 10.04.03 Is there any way I can get hold of the previous version? I am downloading 11.10 at the moment as suggested. – Alastair Feb 18 '12 at 14:09
  • Downloaded ubuntu 11.10 but I still have the same problem, I have tried it on 3 different usb sticks. Version 11.10 an 10.04 dont work through usb. Ubuntu Server usb boot just reboots when I hit 'enter' for 'Install Ubuntu Server' option. Any ideas would be welcomed! – Alastair Feb 18 '12 at 18:09

Ah! I don't know what I didn't see this before. The Ubuntu Server install CD isn't meant to be a LiveCD - not the way the Desktop edition is anyway. That makes sense why the USB Creator isn't making an actual bootable disk. Luckily, I have a lot of experience in this area, so at the very least I'll give you instructions on how to make a bootable USB from the contents of the disk - once I finish downloading the disk.

OK. Here we go:

  1. Extract the contents of the CD image to the USB drive
  2. sudo apt-get install syslinux
  3. Find the device name of your flash drive (mount and look for the label. Then you want to find out what /dev/sdX1 it is on. It'll be /dev/sda1, /dev/sdb1, /dev/sdc1, etc. We'll call it /dev/[flashdrive]1
  4. syslinux -i /dev/[flashdrive]1
  5. dd if=/usr/lib/syslinux/mbr.bin of=/dev/sdX (/dev/sdX is whatever drive your flash drive is WITHOUT the following number)
  6. Then try booting it (or running it in a virtual machine like qemu-kvm to make sure it works)

The instructions are pretty much the same if you're doing it under Windows, but you need to download the Windows version of syslinux and run it like syslinux -m -a F: (where F: is your USB drive) and you don't need anything to replace 'dd'


I suggest two options:

  • Try Ubuntu Server 12.04 LTS
  • Or, try Ubuntu 10.04 Alternate Install ISO**, and choose "Install a command-line system"




Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.