0

I've seen a lot of posts on this topic, but I couldn't find anything yet to solve my problem. I recently removed my linux partition (to keep Windows), and upon starting my computer up, received the message from grub loader:

error: no such device : #long number#

Entering rescue mode..

grub rescue >

I've found at a lot of places that rebooting it using a windows recovery usb stick, entering the command prompt and typing

bootrec.exe /FixMbr

bootrec.exe /FixBoot

would restore the windows (Mbr?) bootloader. However, when I typed these commands, it said that it had succesfully completed these actions, but upon restarting my computer, it gave the same error message as before.

I've also tried to make a boot-able usb to boot the boot-repair with Rufus, however, my computer (Windows 10, Dell XPS, old model from apprx 6 years old) won't recognize this usb to boot from.

I'm completely lost why these things won't work. If anyone has more experience then me and has an idea, please let me know.

Thanks in advance, Cheers

  • Thanks for thinking along! Eventually, it turned out, using a different usb stick for the boot repair program solved the problem! – marindat Jul 8 '18 at 11:49
1

The simplest solution is reinstalling Ubuntu. You can then delete Ubuntu partition again and follow this tutorial to remove GRUB files. After that, You'll be able to boot Windows directly.

  • Thanks for you answer! Stupidly, trying another usb-stick solved the problem of the boot repair not loading, thanks for thinking along though! – marindat Jul 8 '18 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.