3

I own a MSIGL62 6QF gaming laptop, I recently changed my OS to Ubuntu, but the problem is that Ubuntu freezes in the Splash screen, the only solution that I found working was entering to the safe mode of Ubuntu and put nouveau.modeset:0, the problem is that I have to do it every time I use Ubuntu.

In internet they said that is nvidia but I already have my drivers installed, I really don't know what to do.

Please help me, thank you.

2 Answers 2

7

If you require noveau.modeset=0 in order to boot properly, you could add an extra kernel boot parameter in the /etc/default/grub file so that you don't have to type it in (and can continue to use the open source nouveau drivers).

Boot up using your 'safe mode' solution and then open a terminal and use

sudo nano /etc/default/grub

to change

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to be

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

(press Ctrl + x to exit, y to confirm saving the changes and Enter to accept the filename)

If you then run sudo update-grub to update your changes, when you reboot it should work as if you'd typed that line in yourself each time.

1
  • Glad that helped! I don't have nVidia graphics myself but i was investigating a suspend problem and found the 'nouveau.modeset=0' trick was working for people. Also worked for someone trying to just get the Live USB to boot properly. Apparently it might have something to do with a bug in the nouveau driver for 18.04, which means it should hopefully get fixed at some point in the future and the modeset trick might not be necessary.
    – pHeLiOn
    Jul 8, 2018 at 17:14
3

It seems you're using open source Nvidia Nouveau drivers. Try to install proprietary Nvidia driver instead. First of all check which version proprietary driver is suitable for you, run in terminal:

ubuntu-drivers devices

You'll see something like this:

== /sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0 ==
modalias : pci:v000010DEd00000A65sv00001043sd00008354bc03sc00i00
vendor   : NVIDIA Corporation
model    : GT218 [GeForce 210]
driver   : nvidia-340 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

Pay your attention to the line with distro non-free recommended - there is exact name of package you may install - in the example above it's nvidia-340. Install the detected driver (change driver version 3XX in the command below to your detected version):

sudo apt install nvidia-3XX

Reboot computer:

sudo reboot

Check Nvidia proprietary driver in use, run in terminal:

nvidia-smi
4
  • I already did you what you propose but I still getting stuck in the splash screen. Jul 8, 2018 at 13:03
  • I did it then the terminal got stuck in the Building initial something, I tried restarting the laptop but the Ubuntu didn't boot, I had to to reinstall the OS. Jul 8, 2018 at 14:58
  • Building Initial module, it got stuck there for 1 hour (I had to turn off the laptop). Jul 8, 2018 at 15:54
  • For others out there worried about the “non-free” tag. This does NOT mean you have to pay, it just means the software is bound by a proprietary license. I love FOSS as much as the next dev, but my computer works perfectly now with no workarounds, this should be the accepted answer…. If you’re interested you can read the full license here. It’s pretty simple you can use it for whatever you want (mostly) just don’t reverse engineer or modify the binaries. Jun 28 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.