(refers to Ubuntu 11.10 Oneiric)

I set up a printer connected via USB (Canon MP630) and a network-printer (Brother HL-2030 via Fritz!Box 3270). When I try to print something the files get sent to the printers (Ubuntu says so) and the printers get activated: They wake up from standby (if so) and (Canon) show a message "start printing" resp. (Brother) sound like they would start printing. But two seconds later everything stops and nothing happens anymore. Ubuntu said everything got printed.

How can I solve the problem and print again? How to gain more information of the process? Everything worked well in Ubuntu Natty 11.04.

And it might be of interest that it is no problem to scan anything with Canon MP630, as well as I recieve status-messages.


I deleted both printers again, rebooted and installed them newly. Now it works partly:

(Brother HL-2030) I used to choose the original Brother-ppd when it didn't print. When I took the Ubuntu-recommended one I now can print, but can't configure all the options I was used to configure (i. e. Sleep-Time ...)

(Canon MP630) I can print now, but it is totally messed up: It prints 1mm-lines of colour and between each line is a blank line. So it prints only the upper part of an image and at all it looks pale and stretched.

  • I think you need to reinstall the printer. – Gigili Feb 18 '12 at 12:24
  • I already did do this, more than once. Both. – Jakob Feb 18 '12 at 12:26
  • Oh? That's weird. I was suffering from the same issue and reinstalling fixed it. – Gigili Feb 18 '12 at 12:29
  • Reinstalling after a reboot fixed it partly. I added information upside. Thank you for pointing this out! – Jakob Feb 18 '12 at 13:29

Found this on ubuntuforums.org regarding your Canon. People say it works on 11.10 as well.

| improve this answer | |

You could try checking in /var/log/cups to see if the error logs give you any extra information? (CUPS is Common UNIX Printing System)

The reason Ubuntu "thinks" it printed is because it was successfully spooled off the the printer (loaded into the printers memory). At that point, Ubuntu doesn't have to worry whether the physical printer finished its job. I haven't done much printing at all in Linux for years, but that's how I understand spooling to work.

| improve this answer | |
  • /var/log/cups/access.log says always Print-Job successful-ok. And I read the situation as you do. So it seems to be a driver-problem? – Jakob Feb 18 '12 at 13:33
  • Yeah, but on two different models? That's too weird. AND the fact that the printers do wake up... – Chuck R Feb 18 '12 at 14:04
  • May be it's because of trying to install original drivers for both models. – Jakob Feb 18 '12 at 14:57

Canon MP630

Works fine with the original drivers, which I couldn't install due do dependencies.

How to solve this is described here. (It's in German, but I think understandable. You have to replace libcupsys2 by libcups2 in a text editor ...)

Brother HL-2030

Also works with original drivers! I took a new attempt to install them from the official site and also installed the lpr-driver linked there. Then reinstalled the printer and chose HL2030 for CUPS (not HL-2030) - now everything is again as I know it from 11.04. Fine!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.