I'm trying to find the control panel that will let me configure various things about my touch pad such as disabling it when other devices are active and what not. I keep accidentally touching my touchpad while I am typing which causes the cursor to jump somewhere else and then text goes there until I realize what happens and have to try to undo it. I want to be able to have the touchpad ignored when I am using the trackpoint on my computer somehow. The only setting I can find at all related to my touchpad is Preferences -> Keyboard and Mouse, but it is very minimal and doesn't even touch on the touch pad.

In my research I found that there is a package called "gsynaptics" that I need to install after which I should run gpointing-device-settings. However, when I try to install it, it says the package is not found, and when I try to run gpointing-device-settings it doesn't suggest any repositories I could find it in. I have also noticed that most questions about this topic are several years old and in one place it suggested that gsynaptics is no longer used (but then they went on to indicate that they had, in fact, installed it, without saying how).

From what I have read, this package was in Universe, but under "Software and Updates" the "universe" setting is already checked.

Where can I find the package to let me configure my touch pad in LUbuntu 18.04 in this way?

  • Have you installed gnome tweak tools? – PRATAP Jul 7 at 22:43
up vote 1 down vote accepted

It appears that gpointing-device-settings was removed possibly due to never being finished and debugged.

In any case, I found touchpad-indicator (site is in Spanish, but Google translated it for me pretty good), also with the code here.

I installed it using:

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator

And then running touchpad-indicator I got an icon in the task bar. Clicking on it brought up preferences. Note that the icon was very light by default for me, but under the icon -> preferences -> theme you can make it darker if you like. It also crashed on me the first time with something about a missing file, but the second time I ran it, it seemed to work fine. It may be necessary to manually add it to the default apps for LXSession (under LUbuntu menu -> Preferences) so it will start whenever you log in.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.