2

I have had an issue with sound ever since I installed Ubuntu. On boot up I can select HDMI sound and it works, when the monitor sleeps one of two things happen.

Either the sound reverts to another source and I have to switch back to it in the settings, which is annoying but not unrecoverable, or the sound stays on the HDMI source but I get no sound and have to reboot to get it back.

throughout this the HDMI source is always available and I can select it. but I always have one of the two issues.

I am loving the experience with Linux at the moment but this is starting become a deal breaker, can someone please help ?

thanks

6

Simple Solution

When signal is lost to HDMI (during sleep) Pulse Audio is automatically configured to active source (your laptop's speakers). Upon resume the sound device is still your laptop. To override this setting, tell Pulse Audio to never switch sound devices automatically:

  • edit the file /etc/pulse/default.pa
  • find the line load-module module-switch-on-port-available
  • insert a # at the beginning of the line to disable automatic port switching
  • save the file and reboot.

Complex Solution

Before I learned of the simple solution, I used a more complex solution based on systemd suspend/resume hook:

An even more complex solution for when HDMI TV is unplugged and replugged is based on udev rule:

Extensive Forum Thread

In Linux Mint forum there is an extensive thee page thread on this topic:

  • Hey thanks for the reply, unfortunately I have already done this with no joy. – John Dowling Jul 8 '18 at 5:12
  • @JohnDowling I've expanded the answer with more complex solutions you may not have tried yet. – WinEunuuchs2Unix Jul 8 '18 at 14:25
  • I have implemented the first of the complex solutions I will let you all know the result soon – John Dowling Jul 8 '18 at 16:22
  • the solution seems to have stopped the audio switching but has not solved the second of the two possibilities, after wake I have no sound at all, so we seem to have solved the annoying issue but not the deal breaker one lol – John Dowling Jul 8 '18 at 17:09
  • In fact scratch that, on the last reboot the audio switched back to spdif – John Dowling Jul 8 '18 at 17:16
0

Ok So it would seem that the only way I can solve this is to unplug and plug in the hdmi cable after waking, this is better then rebooting but still not Ideal.

I am going to mark this as solved, but if someone has a better suggestion please let me know.

0

Ok that's it i'm out.

Until the audio can be fixed on this platform it is a null platform.

Have completely lost sound now, this is a poor showing for 2018.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.