6

I want to make a copy of a DVD with Brasero. But it asks for libdvdcss.so.2.

I already did what was suggested at How should I install libdvdcss.so.2 (Library) to Ubuntu 16.04

But it didn't work.

2 Answers 2

10

This worked for me

Try (this may not be needed for Ubuntu 20.04)

    sudo apt install libdvdread4

Do

    sudo apt install libdvdnav4 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libdvd-pkg
    sudo dpkg-reconfigure libdvd-pkg 
    sudo apt install ubuntu-restricted-extras

After that I was able to copy the DVD with brasero.

3
  • 1
    Ubuntu requires the additional command sudo dpkg-reconfigure libdvd-pkg after the first command above. Aug 13, 2018 at 20:07
  • On Focal 20.04 it's libdvdread7 now.
    – Tully
    Dec 12, 2020 at 20:27
  • libdvdread4 (or 7 on Focal) is not enough. The package libdvd-pkg (it's included also in the first line under Do above, so the commands under Do work.
    – OndroMih
    Dec 25, 2020 at 21:20
8

For Ubuntu 20.04

sudo apt install libdvdnav4 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libdvd-pkg
sudo dpkg-reconfigure libdvd-pkg
sudo apt install ubuntu-restricted-extras

To do the above without user interaction, add -y after each apt install and --frontend=noninteractive after pkg-reconfigure.

Note libdvdread4 is unavailable in Ubuntu 20.04, but seems unneeded.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .