I installed NVIDIA GT 1030 proprietary driver for Linux X86 64 bits in Ubuntu 16.04 LTS. Since, Ethernet driver module becomes unstable; it does not start automatically after login or resume after suspend until I type $sudo modprobe r8169. I tried to fix the problem using $sudo systemctl restart network-manager.service, but in vain.

I went through the forums and learned that this module is unstable and the best way to get things work is to return back to r8168 driver. I blacklisted r8169 in /etc/modprobe.d/blacklist.conf and tried to compile r8168 for my 4.15.0 linux kernel, however it does not. I tried to install r8168-dkms package from the repository but does not succeed.

Now I have r8169 driver working but with Networking Interface initially UNCLAIMED. Any help is welcome.

  • 2
    Please give me more detail about the errors you received when trying to install r8168-dkms. Regarding "unclaimed", did you manually remove your entry in blacklist.conf? Report back to @heynnema.
    – heynnema
    Jul 7 '18 at 16:38
  • @heynnema: the build process of r8168-dkms failed and reported the following error: 'ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/r8168-dkms.0.crash' Error! Bad return status for module build on kernel: 4.15.0-24-generic (x86_64)' About the unclaimed network device, I edited the file '/etc/modprobe.d/blacklist.conf' to install NVIDIA driver, then undo all the changes.
    – Oualid
    Jul 7 '18 at 17:51
  • What version r8168-dkms driver are you using?
    – heynnema
    Jul 7 '18 at 18:53
  • @heynnema: it's 8.041.00
    – Oualid
    Jul 7 '18 at 19:04
  • That's too old for the 4.15 kernel. Are you getting that from Synaptic? You probably need the .045 bionic driver. Get it at packages.ubuntu.com/search?keywords=r8168-dkms. Also, understand that the -24 kernel has number of issues, and you might try booting an earlier version, and see if that helps. If any of this helps, let me know, and I'll write a formal answer for you to accept.
    – heynnema
    Jul 7 '18 at 19:09

From the comments...

Using r8168-dkms 8.041.00 with the newer 4.15 kernel on Ubuntu 16.04 LTS won't work. You'll probably need 8.045.

The bionic version, r8168-dkms 8.045.08-2 from https://packages.ubuntu.com/search?keywords=r8168-dkms wouldn't compile. The cosmic -3 version would have probably worked fine.

r8168-dkms 8.045.08-3 from http://mirrors.edge.kernel.org/ubuntu/pool/universe/r/r8168/ works fine.

The system is operational now.

Note: kernel 4.15.0-24-generic has some known issues. Best to use another kernel if other problems arise.

Update #1:

r8168-dkms 8.046.00-1 has become available at http://mirrors.edge.kernel.org/ubuntu/pool/universe/r/r8168/r8168-dkms_8.046.00-1_all.deb

Update #2: (August 2019)

r8168-dkms_8.047.02-1 is now available at here.


Here's what worked for me under Linux Mint 19.2

  1. Grab a copy of the latest r8168 driver (or download it via another computer and put it on USB storage)

     wget http://mirrors.edge.kernel.org/ubuntu/pool/universe/r/r8168/r8168-dkms_8.047.02-1_all.deb
  2. Install that driver (will automatically regenerate initramfs kernel image with integrated driver)

     dpkg -i r8168-dkms_8.047.02-1_all.deb
  3. Remove elder driver, blacklist it, and use newer one

     rmmod r8169
     echo "blacklist r8169" | sudo tee -a /etc/modprobe.d/blacklist.conf
     modprobe r8168
  4. Profit (and try if everything works after a fresh boot)

  • I need to report this. I downloaded the driver and run the install as quoted in question 2 but I got an error message so the initramfs kernel was not updated. I am using Kubuntu 18.04 (latest version) with latest kernel 5.0...
    – user25406
    Oct 15 '20 at 17:42
  • 1
    You should not override your entire blacklist.conf file. The command should be echo "blacklist r8169" | sudo tee -a /etc/modprobe.d/blacklist.conf
    – Terrance
    Mar 12 at 14:13
  • Good catch, thanks. Mar 15 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.